Unable to publish CAF and Task projects from Designer to MWS over Https protocol


We have recently configured the SSL on our MWS server and the server currently runs on a https port. The http port is disabled.The SSL implementation seems to be fine, as we are able to see it as a secure connection over browser and also we have re-configured the IS connection to Task engine and it is working as expected.

However we are having 2 issues currently:

  1. We are unable to publish the CAF projects from Software AG Designer to MWS over the Https port. Please let us know if there are any additional steps to be followed to import the certificates in Designer as well, or what could be the possible cause for this issue.
  2. We are also unable to use the MWS server over https port in the Deployer and is giving an error as below:
    Error connecting to server: [DEP.0006.0024] Plugin System Name: DevMWS, Plugin Type: MWS, Deployer tried to connect to the plugin-server with specified connection details but could not connect. Make sure that you are trying to connect to the correct plug-in server and that the plug-in server is up and running.

Any pointers here would be of much help.


Best Regards


We faced the same issue on our side, the only thing we did was to publish with sysadmin credential over http xx585 port. The secured port xx443 over https did not worked for us.

I know it’s not helping at all but I wanted to let you know that you’re not alone with this issue