Unable to deploy process models anymore


We are currently having a very strange issue.
When using the Deployer, if we try to create a build which includes a BPM_SET as well, we get below error:

error=class com.wm.app.b2b.client.ServiceException
errorInputs= >>>projectName=CLIP_Process, projectNameList=[0]My_Process, action=add, actionList=[0]add, buildName=myBuild, buildNameList=[0]myBuild, buildDescription=, buildDescriptionList=[0], submit=Create, submitList=[0]Create<<<
**User not authorized to lock/unlock Project.

We even tried to check the No flag for the Deployer Setting Project Locking Default but no result.
Our users are in the Administrators ACL.

Our server settings:

Product Information
Name webMethods Deployer
Build 161
Patches Applied DEP_9.9_Fix7,DEP_9.9_Fix6,DEP_9.9_Fix4,DEP_9.9_Fix3,DEP_9.9_Fix2

Can you please let us know what might be the cause of this issue?

Thank you in advance!

Hi Madalin,

please add your users to the DeployerAdmin ACL additionally.

Are the RemoteServer (in IS Admin UI) and the LogicalServer in the WmDesigner package defined correctly?


Hi Holger,

Thank you for your reply.
I have checked the mentioned settings are everything seems to be ok.
The strangest thing is that we get this error only when trying to deploy processes in WmDeployer. If for instance we were to try to create a build based only on a IS_SET (no process models), then it would work without any issues.
Are there any additional permission settings which need to be taken into consideration when trying to create a build based on BPM_SETs (process models)?


Try recreating the Deployer project.

Your current project might be missing some ACL which are created during the project setup automatically.

Best regards,


Unfortunately I have already tried this approach but I am getting same error when trying to create the build which includes process models.

Thank you,