UM JMX Port not working

Hello Gents,

I have enabled the JMX port of UM from Enterprise Manager --> Config Tab.

But when I try to connect it from Java Visual its not happening. JMX port of IS is working as expected but not of UM.

Am I missing something here? Have restarted the UM as well to see if it’s working on not.

Regards,
Syed Faraz Ahmed

Hi Syed ,

Did you try the steps mentioned in the following KB article :
https://empower.softwareag.com/sl24sec/SecuredServices/KCFullTextASP/viewing/view.asp?prdfamily=IBO&KEY=116632-4465756&DSN=PIVOTAL&DST=TCD

Mentioning the steps here in case you don’t have access to empower.

The steps are as follows:

  1. Ensure EnableJMX is set to true for the realm to be monitored. Open the realm in Enterprise Manager and go to Config tab. Ensure EnableJMX under JVM Management is set to true.

  2. Edit the UM config file. In v9.7, edit nserverdaemon.conf (if running realm as a Windows service) or nserver.conf if running as an application.
    In v9.8, edit Server_Common.conf.

Look for the following existing line:

wrapper.java.additional.?=-Dcom.sun.management.jmxremote

Then add the following lines:

wrapper.java.additional.?=-Dcom.sun.management.jmxremote.port=X (this is the JMX port used to monitor the realm, eg. 8999)
wrapper.java.additional.?=-Dcom.sun.management.jmxremote.authenticate=false (this will disable password authentication ? see Note below)
wrapper.java.additional.?=-Dcom.sun.management.jmxremote.ssl=false

Replace ?? with a number that?s in sequence with the other numbers.

Note: This configuration is insecure. Any remote user who knows (or guesses) the JMX port number and host name will be able to monitor and control your Java application and platform. While it may be acceptable for development, it is not recommended for production systems.

  1. Run Java VisualVM, i.e. a JMX tool.

  2. First, add a JMX Connection.

  3. Then, enter the UM realm host name and JMX port. Credentials are not required.

1 Like

Hi Rakesh,

Thanks a lot for sharing the article link.

It helped and I am able to connect to JMX port of VM successfully.

Regards,
Syed Faraz Ahmed

Hi Rakesh,

I fallowed all the steps which you have suggested and still i am unable to connect to Java Visual VM.

UM Server 10.3

Regards,
Suresh

Are you sure? Its 3 step process

1> Enable the JMX on UM config for JVM Management
2> Edit the Server_Common.conf
3> Restart UM

If your UM is installed on the same machine where you have Java VisualVM installed it will automatically pull the details for you (verify by pid)

Also, make sure the JMX listening port specified is not currently being used by any other process on the host where UM is running (e.g use cmd “netstat -a”)

Hi Mahesh,

The port which i am using is 8080 and it is free when i checked with netstat-a. Please find the setup details below if it can help you to understand further.

-I have installed all three UM servers in same VM.

-I am using Java Visual VM app from -> C:\Program Files\Java\jdk1.8.0_40\bin

-UM version is 10.3

Regards,
Suresh

Let’s enable the jmx on one of the UM server and then jump on to others.

Firstly don’t use 8080 use 9979 instead.

Share the UM config and server common conf files let me have a look at them.

Hi Mahesh,

I have resolved the issue. I didn’t renumber the sequence properly and that is why i faced the issue. Thanks for the help !

Thanks,
Suresh