Typical question on storage of data

Hi All,

I am getting a data of length 6 Lac characters from a storedProcedure. when I tried to call the storedProcedure from webMethods flow service, as part of variable to which the output of SP assigned, it is holding a max of 4000 characters where as my storedProcedure may return a data of 5 lac to 7 lac characters based on the input we pass. Kindly help me how can I get the data properly.

Thanks a lot for your help on this thread.

Thanks,
RP.

You mean the SP pipleline results list output is showing 4000 records/rows ONLY?

HTH
RMG

Thanks RMG for your swift response.

I have a variable @XML_OUTPUT which is of type XML in my storedProcedure as part of SQL server. I tried to read it in webMethods by keeping input type as BCLOB/CLOB and output type as String after which I got Inconsistent datatypes error. Henceforth, in storedProcedure, I converted @XML_OUTPUT to NVARCHAR(MAX) type. Now in wM adapter service I specified ParamJDBCTtype as nvarchar for @XML_OUTPUT and outputType as java.lang.String.

When I run this adapter service it is not having all the data which is send by storedProcedure.

when I run the storedProcedure by passing n ( no. of records to pull ) below is the observation.

For 5 records in DB, content length is -> 12978 characters, the length of string in webMethods is only 4000
For 15 records in DB, content length is -> 36768 characters, the length of string in webMethods is only 4000
For 55 records in DB, content length is -> 166992 characters, the length of string in webMethods is only 4000

Please let me know if you need any details from me.

Once again thanks for your help on this.

If you are working in designer, It will not show entire pipeline data if string is longer(i am not sure about length it show)

Try to write it to file and confirm your observation

Thanks Sai for your response. I tried to write but its showing only partial content which it displayed after running Adapter service.

Thanks,
RP

Dear All,
Can someone help me on this …?

Thanks,
RP.

Hi R P,

Could you try to check your ‘web.config’ and see if there is anything you can do to modify max string length under <system.web> tag and later try to check the output in webMethods, in case the output in Designer/file is still incorrect.

Regards,
Vikas

Thanks Vikas for your reply.

I am using wM8.2.2.2 , Developer. Can you please tell what is the exact file name of ‘web.config’ and its location if possible.

Thanks,
RP.