Transaction not working

Hey guyz got an issue here with transactions, i have gone through the docs but didnt help much anywayz i have 3 services(retrieve,transform & send) running start,commit & rollback transactions … the first service i.e. retrieve works fine if i disable the other transactions in other steps, hve also checked the error log only thing i get is [SCC.0121.0036E] transaction timeout the retrive service just keeps going and never stops. Any solution to this problem ? i hve tried to regenerate my model using modeler, also the OPTIMIZE LOCALLY option in modeler unchecked … need help asap. thanks,

The resource is already being used in a parent transaction?? what does this mean ?

Im using Transaction Type LOCAL_TRANSACTION in the retreive service where im doing a select and in my Send service using XA_TRANSACTION using a BatchInsertSQL … if tht helps…

still no takers … RMG or Mark plz help.

The resource is already being used in a parent transaction - it looks like the integration is already started a tranasaction with this name and didnot use commit or rollback. If you are trying to start transaction with same name then you could see this error.
Make sure you commit or rollback transactions with same start transaction name in your services.


Hope you got the answer from Krishna.

Sorry for the delay response,