The metadata for IDoc of type xxxx could not be found in repository with system

Hi I am trying to post an IDOC into SAP ECC 6.0 and i am getting the following error:
The metadata for IDoc of type “DELVRY01” could not be found in repository with system id xxx.

Did anyone face this issue before, if yes, whats the resolution for this problem.
WM Env : Adapter 6.5, Developer 7.1.2
SAP Env : SAP ECC 6.0.

This is urgent and we are kind of struck in our testing efforts. Plz help

thanks for the help in advance.

this is urgent. can somebody reply plz…

As per the error the metadata for the IDOC is not able to get loaded into webMethods.

1)Most probably its an authentication issue in SAP system for the User configured in webMethods to connect to the SAP system.

Checkpoint
Try to create an ISDocument from the IDOC through Developer.

If this also fails…can you give some more background of the issue?

svreddy,

Yes good point,this would be the best bet,to check the metadata connection SAP–>wM

“Try to create an SAP Document Type (plug-in) from the IDOC through Developer.”

HTH,
RMg

RMG,
Yes i did try to create an SAP Document type using the plug in and it failed to create it.

We tried so many things, like bouncing the server, disabling/enabling the connections and listeners etc. still doesnt work.

Regarding authorization, SAP basis has granted SAP_ALL to our user.

Any help plz ?

As you know we mentioned what ever possibilities to help you…you may have to work more with BASIS team to resolve this…Did you talk to SAG tech support also?

I believe some goofy going on between SAP–>wM authorization/connection aspect.

HTH,
RMG

This is happening since about 10 days now, I worked with BASIS exclusively on this issue, as i reported them that this could be happening because of some authorization, they put a trace and nothing is captured. then just to satisfy us, they even granted SAP_ALL authorization to see if it resolves. It didnt help either.

Yes, we created ticket with webmethods tech support on last Friday, but havent heard back from them.

Just to give little background, it was working for months and suddenly this issue came up. both SAP and webmethods claim that nothing has changed on their side.

Any suggestions Plz ?

I can understand your pain…Also did you refresh/reload the DDIC cache on the SAPAdapter admin page? Yes,tech support help response sometimes sucks with delays…

HTH,
RMG

RMG,
Yes I did clear the DDIC cache, even though i know this is not related to the issue.

Thanks RMG for responding.

Once we fix this, I will post the solutions to this issue.

Have you checked this article on advantage?

http://advantage.webmethods.com/article/?id=1614328006

HTH,
RMG

Are you developing the SAP Notification for the first time in the Server or any existing notification is there???

Give some background to your issue…

Also another check …Do you have any other SAP system which u can try on(Posting an IDOC)? If so try the same n check if you see some difference…

OK, here is the solution that worked for us.
the unicode setting was set to yes, we changed it to No and it resolved our issue.

Hope this helps

Is that the issue was?..

We have Unicode setting to yes and no issues with it anytime…it’s still a surprise to me.:confused:

Anyways you got it resolved…cool…

HTH,
RMG

the unicode setting was set to yes, we changed it to No and it resolved our issue.
Hmm, this is strange. The ECC 6.0 should be Unicode, isn’t it? In that case the Listener and SM59 need to be Unicode=yes, otherwise webMethods server can’t read the IDoc name correctly and tries to make a lookup for IDoc name = “?6e5”%^^“039§%”. And of course an IDoc of that name does not exist in the SAP system…
So this would mean your ECC is in fact non-Unicode, is it?

In the past I have seen another issue, causing this symptom: if you have two different SAP systems connected to the webMethods server, one system has the IDoc in its DDIC, the other one doesn’t. And both systems have the same system ID (which is actually not supported by SAP, for a good reason), then its coincidence which of the two SAP systems the SAP Adapter uses for the IDoc DDIC lookup. (The SAP Adapter uses the SysID as key for its DDIC cache and assumes "same SysID = same system = same DDIC = no need to cache the metadata twice. Therefore it does not distinguish between two systems, if they share the same SysID.)

Cheers, Lanzelot

If SAP authorization is ok…
Can you try one thing…?

Disable all other SAP Connections/Listeners in the Server.

Then Restart the server. Now try posting an IDOC…

HTH
Siti

Hi,

Please help!
As I am facing the same problem with posting the IDoc to SAP System.
It says, IDoc …could not be found in repository, I checked in lookup and I can see the IDoc of the same type I am inserting in SAP through the interface.

Thanks in advance!

Regards,
SM

Did you compare the DOCREL (document release) that is maintained in SAP and the Idoc that you are posting .If there is a mismatch , it will produce this error .