The HTTP request is unauthorized with client authentication scheme 'Basic'. The authe

Hi guys,

I am getting following error when i am trying to send a request to a web service and expecting a response.

[SIZE=1]A message sent to adapter “WCF-BasicHttp” on send port “WcfSendPort_view_entityService_view_xxxx” with URI “http://XXXXXXXXXXXX.8798/soap/acsp” is suspended.
Error details: System.ServiceModel.Security.MessageSecurityException: The HTTP request is unauthorized with client authentication scheme ‘Basic’. The authentication header received from the server was ‘Basic realm=“webMethods”’. —> System.Net.WebException: The remote server returned an error: (401) Unauthorized.
at System.Net.HttpWebRequest.EndGetResponse(IAsyncResult asyncResult)
at System.ServiceModel.Channels.HttpChannelFactory.HttpRequestChannel.HttpChannelAsyncRequest.CompleteGetResponse(IAsyncResult result)
— End of inner exception stack trace —
Server stack trace:
at System.ServiceModel.AsyncResult.End[TAsyncResult](IAsyncResult result)
at System.ServiceModel.Channels.ServiceChannel.SendAsyncResult.End(SendAsyncResult result)
at System.ServiceModel.Channels.ServiceChannel.EndCall(String action, Object outs, IAsyncResult result)
at System.ServiceModel.Channels.ServiceChannel.EndRequest(IAsyncResult result)
Exception rethrown at [0]:
at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
at System.ServiceModel.Channels.IRequestChannel.EndRequest(IAsyncResult result)
at Microsoft.BizTalk.Adapter.Wcf.Runtime.WcfClient`2.RequestCallback(IAsyncResult result)
MessageId: {53196267-EEF3-4D5C-B187-E95C9F2344F8}
InstanceID: {46B46762-0A3A-431A-A81A-855C33A8A179}
For more information, see Help and Support Center at

I am working almost four days on this error still no luck. Can some body help me with it.

Thanks,
srinu
[/size]

This looks like if your “client” is some external application you have, and provider is webMethods.

You are sending some request with invalid credentials, and IS returns HTTP code 401, unauthorized.

Looks like if you had some custom hanlder, as IS looks to be listening on http://XXXXXXXXXXXX.8798/soap/acsp , since /soap/acsp is not standard I would check how you have this configured.

A goo way to understand the problem should be by enabling HTTP headers logging and check if you are sending correct credentials. Also test your webservice with SoapUI to verify is working.

Hi,

Were you able to fix your issue? I am facing exact same error.
Please share your solution, I will check if I can use same or atleast it will direct me towards some solution.

Thanks.