Test Look up failure (JNDI Provider Alias)

Hi All,

I’m trying to create a JNDI Provider alias in wM IS 9.8 below are the values passed
JNDI Alias Name : Test_JNDI
Description :Test Provider alias
Predefined JNDI Templates : (selecting UM) but is set to Current Settings while saving
Initial Context Factory : com.pcbsys.nirvana.nSpace.NirvanaContextFactory
Provider URL : Realm server address
Provider URL Failover List -
Security Principal -
Security Credentials -
Other Properties -

While trying to do a test look up it fails with the following message .
Error : Test lookup failed for primary JNDI provider URL “nsp://xx.xx.xx.x:9000/”: JNDI setup failed on RNAME=nsp://xx.xx.xx.x:9000/ .

below jars were copied into IntegrationServer\lib\jars directory from UniversalMessaging\lib and IS was restarted
nJMS.jar; nClient.jar; nJ2EE.jar; nP2P.jar; nAdminAPI.jar; nAdminXMLAPI.jar .

Does the Predefined JNDI template selection got to do anything with this error . Is any other configuration to be for connecting UM and IS . Please suggest.

Priyadharshini Muniyandi.

Hi Priyadharshini,

what you have observed upon creation/saving the Provider Alias is correct.

Selecting the template will fill the fields with the defaults or meaningful sample values, which need to be adjusted to fit the customers environment.

Regarding the Libs:
You should make sure that you have the UM Common Libs installed together with your IS.
By doing so they are picked up automatically during start and there is no need to copy them inside the IS.

Are there any other messages in either server.log, error.log in IS or in the UM logs which mght indicate what went wrong?


no error message that would help solving this error . Should anything be done to avoid the Predefined JNDI templates from being set to current settings ?

Hi Priyadharshini,

I have created a JNDI Provider alias in wM IS 9.8 as you did and copied all jar into IntegrationServer\lib\jars directory from UniversalMessaging\lib. Here IS was down so I did make it up.

I have tested look up successfully. Kindly refer attached screenshot. Make sure your UM is up and running and don’t think any other configuration to needed to connect UM and IS.

Could you try once from starting and hope it will work.


Hi Priyadharshini,

no, this cant be avoided.

This is set automatically upon save.

Usually there is no need to manually copy the jars to IntegrationServer/lib/jars.
Just make sure that you have installed the “Common Library/Universal Messaging Client Lib” and the “Shared Bundles/Universal Messaging Bundle” during installation. Then the IS will pick these up from “common/lib”-folder.

By doing so they will be automatically updated by Update Manager when you are applying fixes to IS installation.
Otherwise you will have to copy them each time after you have installed the fixes to the original location where you have them copied from.


Sorry for the late reply .

@Arun : Thank you Arun I exactly did the same but still not able to connect to the RealmServer.
@Holger : Thank you Holger . I have applied the fixes and copied the jar in IS .

but still the message indicates that it is not able to connect to the Realm Server . But the Realm server is up and running .

I tried creating a connection alias to UM
and getting the below error
"com.wm.app.b2b.server.dispatcher.exceptions.ResourceUnavailableException: [ISS.0153.9051] Error initializing UM session: com.pcbsys.nirvana.client.nRealmUnreachableException: Realm is currently not reachable:com.pcbsys.foundation.base.fException: Retry count=2 exceeded attempting to connect to host " .

Hi Priyadharshini,

The IS and Realm are in same of different machine? Can you try below approach.
It seems that IS is not connected for realm server. Please take the backup of all jar files from IS which you have copied and applied fixes for common library thru update manager. Restart the both IS and realm server and try to same.You said the Realm server is up and running So could you check the enterprise manager has realm server’s security tab. In this ACL tab’s everyone column should be checked. I hope it should work.
Keep update the forum.


IS and Realm are in different machines . I tried connecting to another Realm server from the IS and it works fine .
I believe the issue now is with the UM Realm server .
w.r.t the ACL all are enabled.

Hi Priyadharshini,

So now report a case to global support.


Hi ,

It wasn’t an issue with UM or IS but the port 9000 wasn’t opened for communication to happen.
After making the changes it is working fine.

Thanks and Regards,
Priyadharshini Muniyandi.

Just for you information, in-future check the connectivity by doing telnet.