Terracotta server start in background on Linux

Hi,

I am starting Terracotta server on Linux machine using the ./start-tc-server.sh provided in <SAG_Installation>/Terracotta/server/bin

This starts the Terracotta server on Linux console.

The below ways to start the terracotta in background have not helped.
The terracotta does not come up in the background.

./start-tc-server.sh &
./start-tc-server.sh -d -p pid
nohup ./start-tc-server.sh > /dev/null 2>&1 &

What is the way to start terracotta in background.

Regards,
Revathi

Try this, go to TC bin

nohup start-tc-server -f \tc-config.xml -n &

Hi Mahesh,

When I tried the command as below server did not start.

nohup start-tc-server.sh -f tc-config.xml -n ‘TerracottaServer01’ &

The file nohup.out had the below content.

2016-06-30 08:08:50,405 INFO - Terracotta Enterprise 4.3.2.0.132, as of 20160215-084300 (Revision 46954-26740 from trunk)
2016-06-30 08:08:50,777 INFO - Successfully loaded base configuration from file at ‘/opt/softwareag/Terracotta/server/bin/tc-config.xml’.

Fatal Terracotta startup exception:


You have specified server name ‘Terracotta’ which does not exist in the specified tc-config file.

Please check your settings and try again.


Server startup failed.

My tc-config looks like this…

<?xml version="1.0" encoding="UTF-8" ?>
<tc:tc-config xmlns:tc="http://www.terracotta.org/config"
      xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
      xsi:schemaLocation="http://www.terracotta.org/schema/terracotta-9.xsd">
  <servers>
    <server host="pose01lx0007v.prod.sdt.ericsson.se" name="TerracottaServer01">
      <!-- Specify the path where the server should store its data. -->
      <data>/opt/softwareag/Terracotta/server1-data</data>
       <!-- Specify the port where the server should listen for client 
       traffic. -->
       <tsa-port>9510</tsa-port>
       <jmx-port>9520</jmx-port>
       <tsa-group-port>9530</tsa-group-port>
       <!-- Enable BigMemory on the server. -->
       <dataStorage size="8g">
          <offheap size="2g"/> 
          <!-- Hybrid storage is optional. -->
          <hybrid/> 
       </dataStorage>
     </server>
    <server host="pose01lx0008v.prod.sdt.ericsson.se" name="TerracottaServer02">
      <!-- Specify the path where the server should store its data. -->
      <data>/opt/softwareag/Terracotta/server1-data</data>
       <!-- Specify the port where the server should listen for client 
       traffic. -->
       <tsa-port>9510</tsa-port>
       <jmx-port>9520</jmx-port>
       <tsa-group-port>9530</tsa-group-port>
       <!-- Enable BigMemory on the server. -->
       <dataStorage size="8g">
          <offheap size="2g"/> 
          <!-- Hybrid storage is optional. -->
          <hybrid/> 
       </dataStorage>
     </server>
    <!-- Add the restartable element for Fast Restartability (optional). -->
    <restartable enabled="true"/>
  </servers>
  <clients>
    <logs>%(com.softwareag.tc.client.logs.directory)</logs>
  </clients>
	   <tc-properties>
			<property name="ehcache.storageStrategy.dcv2.perElementTTITTL.enabled" value="true"/>
		</tc-properties>
</tc:tc-config>

What is missing?

Regards,
Revathi

Revathi,
Update below parameter in custom_wrapper.conf with server name to resolve the issue.
#wrapper.app.parameter.6="%WRAPPER_HOSTNAME%"
wrapper.app.parameter.6=

-senthil

Above setting suggested must work, let us know if you still have issues.