Sql server 2000 connection errorCould not connect MicrosoftSQLServer 2000 Driver for JDBCError e ...

Hi All,
I am using IS 4.6. When I am trying to connect SQL server 2000 using wmDB I am getting the following Error:
“Could not connect: [Microsoft][SQLServer 2000 Driver for JDBC]Error establishing socket.”.
URL:jdbc:microsoft:sqlserver://serverName:1433;DatabaseName=dbName;SelectMethod=cursor
Driver:com.microsoft.jdbc.sqlserver.SQLServerDriver
I have kept three sql server jar files in /lib/jars directory.

Can you any body see this problem?.

Hi KKumar

Did you restart the IS after putting the sql jar files in the directory?

Yes, I have restarted IS server.Even though I am getting same error.

Is your SQL Server machine reachable from your webMethods server?
Looks like the server is not able to talk to the database. Try pinging the SQL Server machine from webMethods server.

Thanks,
Pankaj

Search the forum for this issue. It’s there.
I ran into this problem in November. I ended up reverting back to SQL Server 7 as it was not critical for us to upgrade to at the time. There is definitely issues connecting Is 6.01 and below to SQL Server 2000.
I think some have gotten it to work so if you end up solving the problem please post the steps.
Thanks.

You may want to check that SQL Server is configured to listen for client connections over TCP/IP. It may just be configured for named pipes. The simple test from the client side (without disturbing dba :wink: would be smth like this:

try {
System.out.println("\nTrying to open a socket with host "
+ serverName + " and port " + portNumber + " …");
Socket socket = new Socket(serverName, portNumber);
socket.close();
} catch (Exception e) {
fail(“Failed to open a socket. Here’s why:\n(Either there is no machine named '” + serverName
+ “’ or\nnothing is listening there on port "
+ portNumber +”)\n");
}

problem while creating an WmDB alias management connection to SQL Server Database
Could not connect: [wm-cjdbc32-0014][SQLServer JDBC Driver]This driver is locked for use with embedded applications.
can any one please tell the solution

hi
coppy all of the and place it in the integration server/lib/jar
then u will get rid of it
i got rid of it
bye prattipati

spratti,

I’m not sure why you were responding to this post from 2.5 years ago, but your answer is not correct.

The SeqelLink DataDirect jdbc driver is shipped with webMethods IS for internal WM applications such as the IS JDBC adapter pools. The error message above indicates that he was attempting to use it from the WmDB adapter for other purposes.

Mark