[SOLVED] Can't start MWS or IS (logs included)

Hi everybody

Yesterday I had to shut down the VM Server on which I’m working for updates. Today when I want to start My Webmethods Server 9.5 and Integration Server 9.5 it fails.

For the MWS a command prompt window opens but after a while closes again, which wasn’t the case before. The IS service command prompt keeps trying to lay a connection but fails.

Here are both logs for these services:
https://www.dropbox.com/s/orbb1tj8nz7g3hy/logs.zip

I hope this is enough information, if not please don’t hesitate to ask.

Kind Regards
Kevin

PS. IS is still trying to start, if you want an update, just ask. :wink:

From your logs posted I can see that at least the Oracle Database and the Broker are not available.

Please check why these Services were not started during the start of the VM.

Try starting these Services and after they have succesfully started try to start IS and MWS again.

If they still fail please share the the details why Database and Broker did not start.

I assume your VM is a Windows VM, right?

My VM is a Windows 2008 Server, the Broker services have started as you can see in the image below:

And I have tried starting one of the Oracle services that’s set to automatic but hasn’t started. Here I get an error message about seeing a certain log but I haven’t been able to locate this (yet). Plus I’m not even sure this is the right service (I’m still learning to use this software, I’m just an intern so I apologize for my ignorance).

Hope this helps.

Kind Regards
Kevin

Can you confirm that you are able to access Oralce DB with out any issues now ??

Thanks,
RP

I am able to access the Oracle DB manually without problems with the authentication data set in the configuration of MWS.

Kind regards
Kevin

OK guys,

The problem has been found…

In the hosts file unders System32\drivers localhost was set to a static IP address while the server has DHCP enabled. That’s why it couldn’t connect to the Oracle DB or Broker Server.

Thanks anyway for anyone who replied and if this solution isn’t clear please don’t hesitate to ask any questions.

With kind regards
Kevin

Best practice is to use hostname which can resolve to latest IP (Static or Dynamic)

OK, thanks. I’ll keep that in mind.