SOAP response document not passing IIS validation

I have a SOAP integration request that is giving me issues. I will include some high level information because maybe my approach is wrong and include my specific error to see if anyone can help resolve it. Essentially I am having trouble sending back a SoapResponse document to our partner. The one difference is the partner utilizes WS Security to encrypt the data in the request, we decrypt this data utilizing a custom Java service because our webMethods version is 6.5 (IS_6-5_SP2_WebSvcsXML_Fix1, IS_6-5_SP2_Core_Fix4, IS_6-5_SP2_XA_Fix2, IS_6-5_SP2 build number 394). The partner is not able to validate our SOAP response, it does not pass their IIS validation (they utilize .NET). They are not able to give me many details. The difference between our response and the response of their successful partners is the WS Security information in the SOAP header. I am attempting to add that information to the Response header by utilizing the getHeader public service on the request document and then adding it to the response after it is formed. This works. However, there are some tags that are not included in the successful partners and I want to drop them from the Header. To do this I am utilizing WmPublic/pub.soap.utils:getDocument modifying the document’s tags. I then run WmPublic/pub.xml:xmlNodeToDocument. After dropping the tags I run WmPublic/pub.xml:documentToXMLString and then WmPublic/pub.soap.utils:stringToSoapData. When I run this in developer I get an NSRuntimeerror thrown (curiously it just errors to the screen and doesn’t enter the failure sequence of the integration). In the IS error log I see these errors,: java.lang.NullPointerException
java.lang.ClassCastException (curiously on service pub.list:sizeOfList which I never call).

Any ideas on what I am doing wrong or if there is a better way to accomplish what I am trying?