SMTP Mail host

Hi, i’m creating a service that sends a mail using pub.client:smtp service. It’s been working fine until today by getting the mailhost from extended setting “watt.server.smtpServer”.

Now it seems to have stopped and I am getting the following error:

Could not run ‘smtp’
com.wm.app.b2b.server.ServiceException: [ISC.0068.9110] Invalid MAILHOST field: null

However the mailhost is still in extended settings.

Any ideas what could be causing this?

Hi , May be the server is not running up or you may given wrong hostname in the service .

OR else you can check the server connection also

PING the SMTP server by using the command prompt.

The server can be pinged and that seems ok.

We’ve got a service that will read the value in extended settings, and pull it back which can then be mapped into the SMTP service, but it’s quite weird that it’s not doing this by default as it used to.

It just seems to be the pub.client:smtp that can’t get the watt.server.smtpServer value by default. Hard coding the values works so it can’t be the mail server.

Calvin – Error is clearly stating that issue with mail host, you just try to give the mail host details manually ( hardcode it ) without calling a service which pulls data from IS extended setting.

Thanks.

Or else you can create a global variable for SMTP host and use in your code

Hi,

there is a Build-In-Service for this:
pub.utils:getServerProperty

Set the input “propertyName” to “watt.server.smtpServer” and use the output as the input for pub.client:smtp.

See Build-In-Services-Guide for details.

watt.server.smtpServer is a default property which just needs to be set under “Settings -> Ressources” in IS-Admin.

Regards,
Holger