SMARTS HTTP Server 3270 Bridge Already Logged On Error

Re-posted from SAG-L:

I am having some trouble with the SMARTS HTTP Server (version 2.3.1) 3270 Bridge. I can enter one command successful, but anything I do thereafter generates the following error message:

Conversation status

COMULG0006-X UserId already logged on...    

For example, I can enter “UCTRL UA” and invoke an HTML version of the User Activities screen. But if I then attempt to select a function, there is no response. And if I go back to the 3270 Bridge screen and enter another Complete command, I receive the ‘already logged on’ error.

Do anyone have any idea what is wrong?

Could be a number of things, here’s the quick ones to check:

  1. Cookies must be enabled in the browser.
  2. The clock of the host must be set correctly. If e.g. your host is in the US but its clock is set to GMT=local, then it can happen that your cookie is already expired when it reaches your PC (assuming your PC clock is set correctly).
  3. CONV=YES must be set in the HTTP server config.

If you believe all these are set OK, you can use the Natural program attached here to check if in general conversations work with your HTTP server or not. Save+stow it to a Natural library (e.g. XYZ), then start it like http://your.server:port/natcgi/xyz/testconv . It should echo your last two input strings.
The outcome will define where to look next.
testconv.txt (1.35 KB)

Hello Steffen.

Thank you for your reply. It doesn’t appear that any of the three items that you mentioned are at issue here. We have CONV set to YES already.

I would like to download or cut-and-paste TESTCONV but don’t know how to view an attachment to a forum message. Could you tell me how or email the program to me at Steve.Hackett@FTB.CA.GOV?

By the way, I’ve already written a few test Natural programs that successfully recieve input from the web, get ADABAS or DB2 data, then display the information. I used HNANSAMP as a model.


Steve, when you click on the “download” link for that attachment, it should ask you to either “open” or “save”, as usual.

Is this not happening ?

Hello Wolfgang. The only kind of attachments I am familiar with are those attached to an email. I am not familiar with a forum message attachment and don’t even know where to look for it. I looked in Steffen’s text and on the borders and didn’t see anything that looked like an attachment. I just don’t what I am supposed to click on. This is new to me. When you point it out for me, I’m sure I’ll wonder how I could have missed it. Thanks, Steve.

Hello Wolfgang. I can see the attachment now and successfully downloaded it. I don’t know why I didn’t see it before. Regards, Steve.

In the box with Description, Filename etc. for the testconv.txt “attachment” there’s a paper-clip on the right hand side, and below it the text “download”, that’s what you’d have to click on, then you’d be asked to open or save it.

But no worries, I’ve mailed it to you :wink:

In order to see attachments you have to be logged on to the forum.

I ran TESTCONV. Here is what happened:

I received the initial screen:


…and this is what showed up in the Complete log:


I then entered a string of X’s and clicked on the button. My X’s were then displayed as output:


…and this appeared in the log:


I then tried it again a few more times and it worked fine. There were no logon errors.

You probably already know this, but to clarify, I’ll mention that I get the logon error whenever I use the input screen for the 3270 Bridge. (It always works once, then fails.)

I also ought to mention that there is an open log on this issue: #588195.

What would you like me to try next?


We continued by PM, but for the benefit of the audience here’s the outcome:

The actual problem was twofold:

  1. Steve’s HTTP server was using the HTML files (homedir) from the original HTP241 release (no patch level) with the loadlib from HTP241 PL3. These are not compatible. Uploading the PL3 homedir would probably also have solved the problem, but I know we made a few fixes after PL3, so I decided to give him PL4.
  2. They had LOGON=DISALLOWED set in the config. This cannot work for 3270, because it would mean that all users run with the same userID (in fact, Complete’s own userID), what is not possible with 3270.