Simple join mystery

I’m trying to get my first join to work and have run into a bit of a mystery. I’ve recreated the Customer/Product/Order scenario as described in the documentation.

If I enter the following query


I get “XQL Request processed, no object returned”
(not what I’m supposed to get)

but if I remove the predicate and just enter


I get what I expected the first time, which is the associated product node.

As a sanity check, if I just query


I get

<Order_id ino:id=“1” C_ob_id=“1” P_ob_id=“1” />

Any ideas ?

I tried it and got the same result. However examining the Order_id schema, C_ob_id is defined as an INTEGER Infofield so the quotes aren’t neccessary. Try…


…it works. With quotes the postprocessor is used,as you are converting an integer value to a char. Without quotes, no conversion is done so the postprocessor isn’t used. The documented query is therefore wrong.

N.B. Use of the postprocessor can be detected by ticking the Info Only box on the Interactive Interface.

Merry Christmas and a Happy New Year! :smiley:

Then the document about the Join must be wrong :slight_smile: