sftp configuration

Hi,

I have to do sftp by using copssh.I have installed copssh software.I don’t know how to procede further.please help me on solving this.

Thnk you

not really sure if it works with IS. better dig into the documentation.
If you open to other options, we are using JSch from http://www.jcraft.com/
open source, works fine for us. You need to do some java coding though. Samples are good.

Hi,

see the below steps…
When using SFTP command you may need to refer to the installed binary directory /opt/ssh/bin/sftp…
Ensure that the firewalls (inner and/or outer) are opened for the ports that are used
The keys need to be created by an admin person using the webMethods user. Only the webMethods user should have access to the created key files.
Create the public/private key pair by running the keygen program on the unix server
Create directory for storing the public and private keys and the identity file
Send the PUBLIC key to the destination server administrator for installing in the .ssh or respective directory.
NEVER SEND THE PRIVATE KEY!

Hope this helps…however for any sftp case the concept would be the same but procedure might different…

Hi Praveen,

We are using HP Insight Manager for ssh configuration.
Please verify following post installation steps.

  • Rename c:\OpenSSH\etc\sshd_config to c:\OpenSSH\sshd_config.bak.

  • Copy the preconfigured sshd_config into c:\OpenSSH\etc(will be given by webMethods team)

  • Configure SSH user

SIZE=3[/size] Open a command window

SIZE=3[/size] Navigate to \bin folder


SIZE=3[/size] Add windows groups to SSH config:
mkgroup -l > …\etc\group (local groups)
mkgroup -d > …\etc\group (domain groups)

SIZE=3[/size] Add windows user(with which webMethods installation is carried out) to SSH config
mkpasswd -l [-u ] >> …\etc\passwd (local users)
mkpasswd -d [-u ] >> …\etc\passwd (domain users)

  • Generate .ssh folder under windows user profile and copy public key under it.

SIZE=3[/size] Open a command window
SIZE=3[/size] Navigate to \bin folder
SIZE=3[/size] Run the following command: ssh-keygen –t rsa
SIZE=3[/size] Accept default values. Do not specify any passphrase.
SIZE=3[/size] Copy the content of id_rsa.pub and paste it into the file ‘authorized_keys’

  • Restart the OpenSSH service from services.msc or by running there 2 commands


net stop opensshd
net start opensshd.

Many Thanks.

Hi,

IT looks to be OK.it is more or less similar what we have configured.So do you have still problems after exchanging the key pair with partner.

If so What is the error?

BR,
Praveen.

Hi Praveen,

I am facing one issue while configuratio of OpenSSH packages on webMethods server.

[FONT=Helvetica][SIZE=2][FONT=Helvetica][SIZE=2]options.properties file
IdentityFile C:/Documents and Settings/webmethods/.ssh/id_rsa
then space between above bold word creating problem line 12: garbage at end of line; “and”.
how to handle this space problem.

Many Thnaks in advance
[/size][/font][/SIZE][/FONT]