sequence (ignores exit on, and always behaves like exit on success) used in branch (resolved)

hi all,

this is wm9.6

branch (on expression)
expr1: sequence (exit on failure)
map (1) -> x=5
map (2) -> not able to see x in pipeline

in the above kind of code, i’m not able to see the pipeline variables those set in map(1) into map (2)

any help is appreciated

thanks and regards
ajay kumar kasam

This works as expected in wM 9.8 may be some fix is required in 9.6. Check with SAG global support.

Is map 1 and 2 step child step of Sequence?

yes… map steps are very much inside the sequence, definitely seems to be issue with wm96
i will try with wm98 and confirm again if its only issue with wm96

Ok. Later share us your test results.

Ajay – I used wm96 a couple of months ago, I didn’t encounter issue which you stated, can you please cross check once again.

Thanks,

attaching the document with screenshots (for problem with sequence inside branch)

this is not few months back, this issue i’m facing as of today.

any help is appreciated. might be i’m doing some silly mistake which is causing me this problem.
problemSeqInsideBranch.docx (149 KB)

Ajay – Did you reach SAG Support ?

Thanks,

Hi Ajay,

I have tried to create a flow like yours using Designer RCP POC (a lightweight version of 9.7) against IS 9.5 SP1.

I can see the variable y in the second map step.

When the condition on the label of the sequence is not matching, the sequence is simply skipped.
If this is not desired you will have to add more sequences under the branch for the other conditions and handle them accordingly.

Exit on Failure will only fire when a step in the sequence fails.
The depicted code does not contain a step which can fail currently.

Most likely this is used as a sort of Try-Catch-mechanism:

SEQ (EXIT on SUCCESS)

  • SEQ (EXIT on FAILURE; Try-Block)
    – signals success when all steps have completed successfully
    – signals failure as soon as one of the steps fails
  • SEQ (EXIT on DONE, Catch-Block)
    – always signals success

The outer sequence exits if either the first inner sequence has been completed (the second sequence is then skipped) or if the first sequence fails after the second sequence has been completed.

Regards,
Holger

The variable issue, assuming we’re talking about design-time and not run-time, is a Designer bug. Both me and a colleague ran into this recently on 9.6. After applying the latest fix, the issue was resolved.

Percio

1 Like

[duplicate post - ignore]

Holger, your post didn’t help much. But thanks for the explanation.

Percio, answered to the point. yes its a design time designer issue. no issue with run time.

Thanks Percio for sharing the solution. Thanks Ajay for confirming the same.

Thanks,

Thanks Percio for sharing the solution. Thanks Ajay for confirming the same.

Thanks,

There is no solution. Its a bug. I wanted confirmation from forum if its a really a bug, otherwise i proceeded with run-time solution.

Ajay,

You are facing the issue with Designer RCP POC but do you see the same issue with actual SAG Desginer9.x?

HTH,
RMG

OK.

If this is a bug in 9.6 solved by applying a fix, nice.

We are currently finalizing our migration to 9.5.
The next migration will be either to 9.9 or what ever has proven stable until then.

Regards,
Holger