Sending SMIME Message via SMTP

Hi all,
I’m able to send SMIME Message to a WM Service via pub.client.http or a VB http program. The problem is when i switch to pub.client:smtp, the message is unreadable, (with some weird char)
Any clue?


whats the content-type you are defining? is it xml or plaintext or edi document that you are mailing?

Can you pls post some more details about your problem.

I am sending a signed & encrypted SMIME stream(SMimeEnvStream) to mimeStream object of ppub.client.smtp. The email gets delivered but I see no SMIME object associated with the message.

Any help appreciated.


what is the content-type you are setting in the smtp service when passing the smime object?? Are you using any custom content handlers in the IS??


Content-type is not an input to pub.client.smtp unless you are sending as an attachment. Since I am passing sMimeEnvStream as an input to the mimeStream object of pub.client.smtp, there is no attachment for which to set the Content-type. Are you suggesting that I send the SMIME object, which is an xml document as the content, as an attachement to pub.client.smtp ?

I would suggest send as attachment and set the content-type also??


I can try that. What would the correct content-type be for a signed & encrypted SMIME object be ? I have tried passing SMimeEnvStream to the content input object and setting the contenttype input to application/pkcs7-mime and I get serious errors when doing this.

Sorry i am not sure if smtp service can digests the mime content types but may be its “application/pkcs7-mime” or “multipart/signed” might do the trick?? generally the above content-types used in the EDIINT transmissions AS1/AS2…



I’m using wm6.1.

I need to receive a encrypted message via smtp. It was observed that when creating and sending an encrypted message directly to the required service the header is present but on sending the smime message via smtp, the header details are missing.

When I tried giving yes to the option “Include email headers when passing message to content handler” in the port details, the emails are not getting read by the listener. What could be the reason for this?
It will be greatly helpful if you could provide any insight on this.

Thanks for your time,


What is the setting of "Invoke service for each part of multipart message." If it is No then change it to Yes and give it a try.

Hi Suren,

Thanks a lot for your reply. I’m sorry for not being able to respond earlier.
“Invoke service for each part of multipart message” is given as ‘Yes’ only. Despite that emails are not getting read when “Include email headers when passing message to content handler” is given as Yes.