scheduler not working


i am using IS 4.6 and i had problem with the scheduler, i want the task to be executed at 6 am from monday to friday regularly but this is not happening i had configured 2 more schedulers one runs for every 5 min and another runs on a specified date. i am not even getting any error message in the logs of IS…

help me in this issue

thanks and regards

How have you determined that “this is not happening?” What I’ve seen in these situations is typically the scheduler is indeed invoking the service but the service is failing and doesn’t log anything or do anything to indicate that it failed. Try putting some pub.debug:log calls into your service to determine if the scheduler is indeed invoking your service and where in your service things may be going wrong.


here the functionality of the scheduler service is to check the file server every day at 6 A.M and if there are any files in the server then it should take them and send to the destination… this should happen for weekdays i mean Monday to friday… but the scheduler is not doing this task…

thanks for your suggestion i will try putting pub.debug.log and reply u again


What is the scheduler status showing…like in when lastRun,Active or suspended etc.?Are you seeing any errors in logs??yes debug log should help you in trace down.

let us know the test results


Scheduler status is active and last run value is never.
When we try putting the same service under repeating task there are no problems.
However we need to have this service to be invoked from Monday to Friday at 6:00 am. Please let us know if there is anything specific that we need to check or set on the server.

As mentioned earlier there are no errors also seen in the error log and server log

Thanks for help.

Can you check in the folder IS/config/jobs.cnf file and see the scheduled job entry is existing or not?Other option would be delete the scheduler or jobs.cnf file and restart the IS,it will recreate the jobs file in the background,later try to create the scheduler once again.I believe this time scheduler should run.


thanks rmg…

we restarted the server but we didn’t delete the .cnf or scheduler … i will do it…