Scheduler did not kick at right time

We are in webmethods 71 platform and we have a schedule task that runs twice in a day at specific time say at 12:15 PM and 16:15 PM. But we observe that the scheduler gets kicked off a minute or 2 minutes later.
Our interface is heavily dependent on the timing. Any idea about the scheduler behavior? Is there any fix?

Thanks
Meena

Hi,

This problem may be related to the “watt.server.scheduler.maxWait” parameter. That is maximum time in seconds Integration Server waits between queries of the task queue.

The server periodically checks the queue for tasks that are scheduled to run. If there are no tasks waiting to run, the server waits the maxWait time before checking the queue
again. If there are tasks waiting to run, the server checks again at the task’s schedule execution time, or after the maxWait time, whichever is earlier. Like take an example if the pending task is due to execute in 30 seconds and the maxWait time is 60, the server will check the queue again in 30 seconds. The default is 60.

so please check the Value of this parameter in IS Console.
Setting → Extended setting

The delay could be for various reasons. If available threads are not available for some reason or all the connections are busy doing other work then Scheduler will just wait execute the task when resources are available. So please check the configurations.

Thanks,
Vinay