scan command - Statement with blank


I am trying to use scan on library command, to find out any objects that use: find number or move left, but according to the manual, the example doesnt work for me. The blank is being used to separete the input values.

SCAN S,MOVE LEFT,MOVE RIGHT,SYSTEM,PGM0*,N,*,N,N - this is what is written in the manual.

I dont want to replace with any value, just find the object using some commands that have two words or - a blank between them.

I have already tried to use IM=F and it was used value for each fields, but none of information was generated.

Does anyone know how to solve it?

btw, Online, it works.


From the manual (four lines above your mentioned example):

“To scan for a value that contains lower-case characters or embedded blanks, do not specify the scan-value in the same line of the batch job as the SCAN command, but in a separate data line, and enter the data according to the online map…”

If you search for “DEFINE DATA” (the Natural session parameter ID is set to the character: ,)


Always use the positional form, if you search for a string with embedded blanks. If you use direct commands: “In a direct command, values containing embedded blanks must be avoided to prevent undesired scan/replace results.”

Hi Helmut,

it worked.