SAP adapter error

Hi All,

We are using SAP adapter 6.5 .When the sap adapter is sending the request to webmethods getting the below error in QA server.
22 10:26:10 CSTwriteTDnowrap(“row-l”); pub.sap.client:createTIDwriteTDnowrap(“row-l”); com.wm.pkg.art.error.DetailedServiceException: [ART.0000.0000] null nullwriteTDnowrap(“row-l”); Stack trace data …writeTDnowrap(“row-l”); a22762e0991711dcac5cc655383350d5writeTDnowrap(“row-l”); a22762e0991711dcac5cc655383350d5writeTDnowrap(“row-l”); a29cb9f0991711dcac5dc655383350d5swapRows();writeTDnowrap(“row-l”); 2007-11-22 10:26:10 CSTwriteTDnowrap(“row-l”); pub.sap.client:createTIDwriteTDnowrap(“row-l”); [ART.0000.0000] null nullwriteTDnowrap(“row-l”); Stack trace data …writeTDnowrap(“row-l”); a22762e0991711dcac5cc655383350d5writeTDnowrap(“row-l”); a22762e0991711dcac5cc655383350d5writeTDnowrap(“row-l”); a29cb9f0991711dcac5dc655383350d5swapRows();writeTDnowrap(“row-l”); 2007-11-22 10:26:10 CSTwriteTDnowrap(“row-l”); pub.sap.client:createTIDwriteTDnowrap(“row-l”); NULLwriteTDnowrap(“row-l”); Stack trace data …writeTDnowrap(“row-l”); a22762e0991711dcac5cc655383350d5writeTDnowrap(“row-l”); a22762e0991711dcac5cc655383350d5writeTDnowrap(“row-l”); a29cb9f0991711dcac5dc655383350d5swapRows();writeTDnowrap(“row-l”); 2007-11-22 10:18:54 CSTwriteTDnowrap(“row-l”); SERVICES:writeToFilewriteTDnowrap(“row-l”); com.wm.app.b2b.server.ServiceException: Path does not exist!writeTDnowrap(“row-l”); Stack trace data …writeTDnowrap(“row-l”); 9e77bdd0991611dcac31c655383350d5writeTDnowrap(“row-l”); 9ed4d1f0991611dcac3dc655383350d5writeTDnowrap(“row-l”); 9ed52010991611dcac3ec655383350d5swapRows();writeTDnowrap(“row-l”); 2007-11-22 10:18:54 CSTwriteTDnowrap(“row-l”); pub.sap.client:lockSessionwriteTDnowrap(“row-l”); com.wm.pkg.art.error.DetailedServiceException: [ART.117.4002] Adapter Runtime (Adapter Service): Unable to invoke adapter service pub.sap.client:lockSession. [SAP.103.9110] WmSAP Adapter: No session ID given, cannot release locked connectionwriteTDnowrap(“row-l”); Stack trace data …writeTDnowrap(“row-l”); 9e77bdd0991611dcac31c655383350d5writeTDnowrap(“row-l”); 9e77bdd0991611dcac31c655383350d5writeTDnowrap(“row-l”); 9eb9a8d0991611dcac39c655383350d5swapRows();writeTDnowrap(“row-l”); 2007-11-22 10:18:54 CSTwriteTDnowrap(“row-l”); pub.sap.client:lockSessionwriteTDnowrap(“row-l”); [ART.117.4002] Adapter Runtime (Adapter Service): Unable to invoke adapter service pub.sap.client:lockSession. [SAP.103.9110] WmSAP Adapter: No session ID given, cannot release locked connectionwriteTDnowrap(“row-l”); Stack trace data …writeTDnowrap(“row-l”); 9e77bdd0991611dcac31c655383350d5writeTDnowrap(“row-l”); 9e77bdd0991611dcac31c655383350d5writeTDnowrap(“row-l”); 9eb9a8d0991611dcac39c655383350d5swapRows();writeTDnowrap(“row-l”); 2007-11-22 10:18:54 CST .
And the SAP adapter logging message is below
2007-11-26 15:56:29 CST [SAP.0110.0002D] Listener - Create 0A22A00C1012474A98C0B99B2007-11-26 15:56:31 CST [SAP.0110.0009D] Inbound tRfc: Execute 0A22A00C1012474A98C0B99B, IDOC_INBOUND_ASYNCHRONOUS from wmuser2007-11-26 15:56:31 CST [SAP.0115.0002D] Notification - Publishing document “createCustomerAndAccountRelPublishDocument”.2007-11-26 15:56:31 CST [SAP.0110.0003D] Listener - Commit 0A22A00C1012474A98C0B99B2007-11-26 15:56:31 CST [SAP.0110.0005D] Listener - Confirm 0A22A00C1012474A98C0B99B2007-11-26 15:56:35 CST [SAP.0103.0013D] Resetting ART connection to alias “sapConnGrp1” in partition “CQ1&%WMUSER&%510&%EN”: com.wm.adapter.sap.spi.SAPConnection
We checked with all connections,listners and notification everything looks fine …and also we tried by restarting the server …but still facing the same …

As this is very urgent issue with client …Could any one please tell me the resolution if you had faced before …

Appreciate your quick response.

Thanks
Gutha

Do you think you might be able to repost the error stack without all the Java script commands sprinkled throughout? It would make reading the error information much, much easier.

Agree with Rob’s post, that is the most useless error message post I have ever seen on wMUsers.

There does seem to be a key phrase in the middle of all that mess. What does "com.wm.app.b2b.server.ServiceException: Path does not exist" mean to you?

Mark

[FONT=Times New Roman]Agree with Rob’s post, that is the most useless error message post I have ever seen on wMUsers.
Hi Rob/Mark,
I apologies for the post which is not cleare.Please find the below error message which am getting .

Pub.sap.client:createTIDwriteTDnowrap(“row-1”);[ART.0000.0000] null nullwriteTDnowrap(“row-1”):Stack tracedata…
Pub.sap.client:lockSessionwriteTDnowrap(“row-1”);com.wm.pkg.art.error.DetailedServiceException:[ART.117.4002] Adapter Runtime(Adapter Service):Unable to invoke adapter service pub.sap.client:lockSession. [SAP.103.9110]WmSAP Adapter.No session ID given,cannot release locked connectionwriteTDnowrap(“row-1”)…

Please advice…

Thanks in advance.

Thanks & Regards
Gutha.
[/font]

Agree with Rob’s post, that is the most useless error message post I have ever seen on wMUsers.
Hi Rob/Mark,
I apologies for the post which is not cleare.Please find the below error message which am getting .

Pub.sap.client:createTIDwriteTDnowrap(“row-1”);[ART.0000.0000] null nullwriteTDnowrap(“row-1”):Stack tracedata…
Pub.sap.client:lockSessionwriteTDnowrap(“row-1”);com.wm.pkg.art.error.DetailedServiceException:[ART.117.4002] Adapter Runtime(Adapter Service):Unable to invoke adapter service pub.sap.client:lockSession. [SAP.103.9110]WmSAP Adapter.No session ID given,cannot release locked connectionwriteTDnowrap(“row-1”)…

Please advice…

Thanks in advance.

Thanks & Regards
Gutha.

Hi Gutha,
looks like an internal error in session management?!
I would contact webmethods support about this.

I know that in many places the SAP Adapter requires a valid User Session to be present in the current InvokeState. (The lockSession Service, which binds a physical RFC connection to an IS User Session, is one of these places.)

Here it looks like you are also using another wM Adapter, which calls into the IS using a “null” User Session. (I have seen this behaviour for example in “Trading Networks”. There may be other Adapters which “misbehave” in such a way.)

Cheers, Lanzelot

Hi Gutha,

Lanzelot is correct, which release of SAP Adapter you are using? If you are using Adapter 6.5 there are patches available for this issue in the advantage site. Apply the patch it will slove your problem, we got same problem with Adapter 6.5. If you want more details let me know?

Cheers,
Jsree