Sales Force Connection issue

Dear all,

AM facing issue while creating the salesforce connecion in webMethods 9.5 free trial veresion.

Its showing time out issue. PFA the snapshot of the issue.

kindly help me out to reslove this.

Thanks,
Raj

Dear all,

PFA the attached snap shot.

we are giving the server URL as “https://login.salesforce.com/services/Soap/u/25.0” and our firewall is disabled.

but still we are not able to enable the connection. its throwing time out error. kindly help us to resolve the issue.

Thanks,
Raj

A Timeout or IO Exception is thrown, when you are behind a proxy server. You need to set-up your proxy setting in the Integration Server:
Settings -> Proxy Servers

and specify the Proxy Alias in Salesforce.com Connector Connection page.

Choose the ‘Advanced View’ (top right-corner), and under “Connection Groups: Connection”, specify the proxy alias against the field ‘Proxy Server Alias’.

Thanks Devashish:)

I have created the proxy alias and configured the same in Advanced settings. this time am getting different error.

Error : “Error while enabling the connection: Error occurred while invoking operations on the SAAS provider., error code: First Element must contain the local name, Envelope , but found HTML

Kindly provide your comments to resolve the same.

PFB the snapshots of the configured values and kindly let me know for any changes

Regards,
raj



@Raj,

Can you please try with following server url?:

https://login.salesforce.com/services/Soap/u/25.0/

HTH.

Thanks,
Rankesh

yes Rankesh,

Am already using the same URL that you have mentioned but still facing the issue. :frowning:

regards,
Raj

Can you try with:

https://login.salesforce.com/services/Soap/c/24.0/

Are you using a Developer Account Or a 30-day trial account?

A typical 30-day trial account does not provide API access, and you cannot use it with CloudStreams. The account should be “API Enabled”. You can refer the link for more information about user access:
https://www.salesforce.com/us/developer/docs/api/Content/implementation_considerations.htm

If you are just experimenting with Salesforce.com, you can get a Developer account at:
http://developer.force.com/

In case you are given access to a sandbox or a different URL, the default login URL “https://login.salesforce.com/services/Soap/u/25.0” will not work for you. Kindly contact you Admin to get the the correct URL to which you would have access.

Note: The CloudStreams Salesforce.com Partner SOAP API v25 works with the Partner WSDL v25. You should NOT be using any other version against this connector. You also should NOT use the “https://login.salesforce.com/services/Soap/c/25.0”, which is used against Enterprise version of the WSDL. [Note the difference in letter ‘u’ or ‘c’, in the URL]

1 Like

Thanks Devashish,

We have created the developer account with the API enabled in administrative settings and we have configured the server URL as = “https://login.salesforce.com/services/Soap/u/25.0”.

But still we are facing the following error while enabling the connection.

Error while enabling the connection: Error occurred while invoking operations on the SAAS provider., error code: First Element must contain the local name, Envelope , but found HTML

PFA the snapshot for the error description.

kindly help us to resolve the issue.

Thanks,
Raj

You attached screen shot error states "Timeout or IOException occurred while connecting to SAAS provider, while your comment reads a different error.

As mentioned earlier, a Timeout or IOException is potentially a cause of missing or incorrect proxy settings. Basically, CloudStreams cannot reach out, and the connection times out. While the error "First Element must contain the local name, Envelope , but found HTML " is an Axis fault typically caused by stating incorrect end-point URL (Either for proxy or the Server EndPoint)

Kindly raise a support request, along-with server log, proxy settings, etc.

Thank you so much Devashish:)

Whom should i raise Request either SAG support group or salesforce support group?

Kindly provide me some pointers to reach out them. it would be much helpful :slight_smile:

Thanks,
Raj

@Rajkumar,

I suggest to cross verify your issue with SOAP UI.

http://blog.deadlypenguin.com/blog/2012/02/03/salesforce-and-soapui/

HTH.

Thanks,
Rankesh

  1. Create a Developer Account with API Enabled Permission in salesforce.com -
  2. Install WmSalesforceProvider.zip in IS downloaded from http://techcommunity.softwareag.com/ecosystem/communities/public/webmethods/products/cloudstreams/downloads/
  3. Export the Partner WSDL from Developer Account page and import in SOAPUI ,remove the headers except username/pwd and Test
  4. While changing the password of the user from salesforce.com , you will get a token which has to be appended with password for making connection/login
  5. Configure a new connection from Solutions>Cloudstreams page of IS for that server URL tested in 3
  6. Enable the Cloud connection alias
  7. Create a Cloud Connector Service in Designer selecting the Connector and Connection Alias - you can use any of the available operation
  8. Invoke the Cloud connector service and Test

For the above error

  1. Proxy setting in IS page and configuration of that alias in Advance tab of connection is must
  2. There is strict enfore encoding - make it true
  3. Sometimes when you delete and recreate the connection it works
  4. Even the working connection, upon re-enabling wont work … so keep trying the above options repeatedly and it works at times…

Suresh Palanisamy
Architect - Cognizant

1 Like

Hey Rajkumar
Did you find a resolution for this issue? I am facing the same problem. However, we are trying with Zuora connection, but similar error while enabling the connection pool.

Error occurred while enabling the connection: Timeout or IOException occurred while connecting to SAAS provider., error code: Connection reset

/Utpal