Resubmit on process step in not working from MWS

Hi folks,

We are facing issue with 3A4 seller model (double action) where if any process step is failing and on resubmitting the process instance from step level, process model is going into resubmitted state and its stays there only without any activity.
The failed steps and later ones are not executing again and there is no logging under “process step summary” however we can see this resubmit action in control action column on MWS.

DB Snapshot: In WMPROCESS table we can see multiple entries i.e. for start, failed and resubmit action as expected but on WMPROCESSSTEP table there is no entry for the resubmitted step with step with increased step iteration, it only contains entry for initial run.
For your reference we have audit logging to save pipeline for failures from IS services however logging level for individual process is set for “process and all steps”

Process instance status from MWS, on resubmission it stays as “Resubmitted” with duration 00, There is no logging for Inbound Map step which we resubmitted from MWS; however we can see that in control actions. We tried to regenerate the model and ran the scanpackage but issue still persists.



What is the PRT fix level?
We had the similar issue and an engineering fix from SAG solved it.

Try to get PRT Fix 5 (which is yet not released for everyone) from SAG.

Also increase the 98, 99, 101 logging level under IS to verbose to see what happens in PRT.


Thanks Sumit for replying.

Infact we are working with SAG to get Engineering fix but unfortunately they are not able to reproduce the problem till now. Can you share the SR number logged with SAG, probably we can refer to get some useful information from there.