REST Client not works


I have created a REST web service with a provider and consumer, into provider I implemented GET, POST, PUT and DELETE services. In the side GET I added two services getTask and serachTask then I want to test if the REST service works with Firefox REST Client but It is impossible to load the file into URL path that not allows to run the test on firefox rest client.
It is important to know I use a Designer on a remote engine.

What is a good procedure in order to execute this process type?

Could you help me please to solve this defect?


Hello All,

When I want to test the web service REST on Firefox REST Client I have the result below :

Status Code: 400 [ISC.0064.9101] Bad Request
Connection: close
Content-Length: 0

See the attached file.

Hi All,

I solved this defect, I used a good URL.


I am seeing the exact same error, but only every other or every third request. Each request is the same, but I am only able to make this happen from the browser (both Chrome and FF). From a standalone REST client. Can you elaborate on your solution?

Hi Andy.
I’ve got the same issue. Can you let me know if you remember what was the problem and how it has been resolved?


I can’t say for sure what Brice’s original problem was, but based on this follow up comment and the screenshot he provided, he wasn’t using a proper URL to invoke the REST endpoint. If you look at this screenshot, he’s missing the ‘rest’ directive, i.e.


Post some details about your endpoint and we’ll try to help you out.


It seems that we found the root cause of the issue.

The external partner/server (Apigee) use GET requests to invoke Integration Server REST services. It looks that in some calls the implementation has been done in wrong way and the GET request contained also body of the message.

Here is the example curl from test with body (we’ve removed all the apigee/implementation specific headers):

curl -X GET -H ‘Authorization: Basic U0lUX0FwaWdlZV9OTDpTSVRfQXBpZ2VlX05M’ -d ‘aaa’ ‘

So in case if curl contains -d ‘aaa’ (that mean body for GET request in that case) and external server (Apigee) invokes several request like that during short period of time, Integration server start to respond
HTTP/1.1 400 [ISC.0064.9101] Bad Request

The main problem here is that the response is not always the same. For most of the request - there response is OK (HTTP 200), but like 1/3 of the requests is with HTTP 400.
From the begging we’ve been suspecting LoadBalancer, but later when we have stated calling one of the server directly - the problem remain.

So the main SAG bug is that the they are not returning the same response for all wrong calls and it was really hard to find the root cause.
Now we are working with SAG for permanent solution of the problem. The SI number is #5314070

?ukasz Konkol