Access denied for user Administrator on port 5555 calling REST-Service over Firefox

Hello,
I just tested the Walkthrough exercise of REST-Services “bookinformation” (AcmeSupport.package) with the standard-installation of wm IS of the EIP (Education Integration Package). At the time I call the get-method “http://local:5555/rest/acme/work/bookInformation/7” from Firefox REST-Client I get the HTTP-code “405 method not allowed” and the server log shows the entry “Access denied for user Administrator on port 5555 ->'rest/acme/work/bookInformation/ from …”

For authentification of the HTTP-request I used administrator/manage.

As I run a student course with implementation of REST-services it would be great if someone has a quick idea how to solve the problem ,because it blocks every further activities of my students.

Regards,
Armin Wagenknecht

I solved the problem on myself. We had a fault configuration in our server settings (initiated by ourselves) :frowning:

Hello Armin,

Can you please explain how you resolved the issue? i mean what changes did u do in the server setup? i am also facing the same issue.
Please let me know!

Hi,
as I rember the problem was that we did not correctly distinguish between lower an upper cases in the URL of the REST-Call. You have to exactly use the lower and upper cases of the folders of your Integration Server where the Flow-Service with the REST Resource ist located.
E.g. the conent of the file GetBookBySKU.txt of the SAG tutorial for the Firefox REST Client is the following:

{“requestUrl”:“http://localhost:5555/rest/acme/work/bookInformation/7”,“requestMethod”:“GET”,“requestBody”:"",“headers”:[“Content-Type”,“application/x-www-form-urlencoded; utf-8”,“Authorization”,“Basic QWRtaW5pc3RyYXRvcjptYW5hZ2U=”]}

This means that your folder structure and naming must be exactly “acme.work.bookInformation”. The “_get”-FlowService must be located in the folder bookInformation.

Our fault was that we named the folder bookinformation not bookInformation. If the URL for the REST call is different to the folder structure you do not get the HTTP code 404 “Not found” but “method not allowed” which is misleading.

I hope that helps.

Best regards,
Armin

In general, we can copy the full REST service name, truncating method names along with ':" and can invoke the REST service from browser REST client.

Thanks,

Hello Armin / MR

Thanks for the reply. I am using Integration server 9.8. Actually the get method is working fine but the post method is failing in my case. The folder structure in the IS is webserviceExample.RESTResource.second_rest and i have a _post method under the folder second_rest. When i hit the following url
http://localhost:5555/rest/webserviceExample.RESTResource.second_rest/_post/
I get the error:
Access denied for user Administrator on port 5555 -> ‘rest/webserviceExample.RESTResource.second_rest/_post/’ from 0:0:0:0:0:0:0:1.

Any idea why it is failing for the post method?

Thanks