Request sent at provider endpoint is received empty

Hi all,
We have an issue on our Integration server 10.3
Trading Networks Server 10.3 Fix 1

we have provider which is exposed via a URL alias and a different https port to some external applications. the servers are in a cluster and have a Load balancer from which the other applications send the request.
the request being sent to us sometimes has no content in it and sometimes it reaches us with full content. the sender says that they are sending it all the time properly but I tried to save each requests received with datetimestamp and have seen that the request indeed has no content sometimes.
the occurrence of this issue is very random. our network team has also confirmed that there is nothing blocking the communication. has anyone faced anything similar?

I have noticed this behavior at least in v9.12 https calls data coming from external entities but couldn’t remember the final solution was

So please raise this issue with SAG support related to v10.3 they may assist more in the troubleshooting and attach all the saved proof’s from your testing!


thanks for your reply. we have debugged this issue with SAG vendor too but not able to reach any conclusion. any idea you have the SR no. with you? anything else to help me point in right direction.

Hi Anjni,

Have you looked at the headers of the empty requests? Please check the Content-length header. If that is 0, it implies that the client is indeed sending an empty request. Gateway servers between the client and Integration Server can modify some headers, but not the Content-length. So “Content-length: 0” means the client sent a request with no body.

Another debugging option, if you have control over the client, is to use an HTTP snooper such as Fiddler.


Thanks for the suggestion. we tried that with gettransportinfo and tracepipeline in the beginning of the service but the content length was always there. the difference that I saw in the logs was that when it was failed we received the data like this
2020-05-22 02:24:01 UTC [ISP.0090.0008C] 0 ApplicationIdentifier {} =>
2020-05-22 02:24:01 UTC [ISP.0090.0008C] 1 @xmlns {java.lang.String} = ‘’
2020-05-22 02:24:01 UTC [ISP.0090.0008C] 1 *body {java.lang.String} = ‘test’

when it was success it was like this
2020-05-22 02:27:16 UTC [ISP.0090.0008C] 0 ApplicationIdentifier {java.lang.String} = ‘test’. this wasnt happening in 9.10 version.

any pointers as to why this happens would help. Thanks in advance.

this was resolved after the fix provided by softwareAG

"It appears that the issue is caused by PIE-54423 that was introduced in Integration Server Core 10.3 Fix 4.

A fix, PIE-57379 was released to resolv the issue in Integration Server Core 10.3 Fix 7. "