Queues and channels disappeared from under JNDI


I have a brand new, single node UM 9.9 installation. Yesterday I had created some connection factories, topics and channels and successfully connected an IS server (on a different physical box) to the UM using JNDI/JMS on secure port 6887(nsps). I have noticed two things:

  1. From EM (on the same box as UM server), I am not able to connect using port 6887 (nsps://localhost:6887). I can however connect using 9000 (nsp://localhost:9000). Is this normal?

  2. All the Connection Factories, Queues and Channels that I created yesterday are still visible on the left side of EM under the realm name, but under JNDI, they are no longer visible. Doing a JNDI lookup from the IS server says “Look up successful”, but does not return any UM artifact list. Yesterday when I had set this up, I received back all the connection factories and queues and channels as a result of the same test lookup. Does anyone know what might cause the artifacts from disappearing from under JNDI?

Thanks in advance

Hello RV,

For point 1 – Are you getting any error message ? I presume you have successfully configured SSL port for nsps.

For point 2 – What is the Fix level of UM server and EM ?

Hello RV,

I recently had the same issue. Here is how I fixed it:

  1. Open EM
  2. Under the Realm name on the left, there should be a folder called “naming”
  3. There is a channel called ‘defaultContext’ in there
  4. Delete the channel, this will make the folder ‘naming’ also disappear
  5. If this is a cluster of realms, you will need to go to each cluster member and repeat the above steps
  6. Now, click on the realm name and then click on JNDI
  7. You will be asked if you want to create the defaultContext. Click on ‘Yes’
  8. Now recreate all the Connection Factories, Queues and Topics

Once all of this is done and you have established that everything is as you want it, right click on the realm name and click on ‘Export Realm to XML’. Save the resulting file somewhere you can access easily. In the future if you have an issue, you can just import this XML and you will be set.

Good to go.


1 Like

Thank you so much root hog. This totally worked. Really really appreciate your answer. Thanks.