Queries on Optimize for Infrastructure & Process configuration

Hello experts,
I have some queries regarding optimize for process & infrastructure setup.
First let me give the details of my setup. I am using webMethods 7.1.1 in windows XP 32 bit environment.
I have 2 windows xp workstation hosts, say W1 & W2.
In W1, I have
a)IS2222 running on port 2222.
b)one Broker server, say BS1 running on port 6849 having 1 broker BrOPTMIZE
c)one Analytic Engine, say AE1 running & listening on default ports (i.e. 15000 & 12503)
d)One webservice data collector, say WDC1 running & listening on default ports (i.e. 15001 & 12603)
In W2, I have
a)IS6666 running on port 6666
b)one Broker server, say BS2 running on port 6849 having 1 broker BrOPTMIZE
c)one Analytic Engine, say AE2 running & listening on default ports (i.e. 15000 & 12503)
d)One webservice data collector, say WDC2 running & listening on default ports (i.e. 15001 & 12603)
e)One Infrastructure data collector, say IDC, running on port 1111
f)One prediction engine say PE, running & listening on default ports (i.e. 15003 & 12513)
g)One MWS server running on port 8585 (with all GUI components installed)
IS settings
a)I have disabled the Administrator user in both the IS.
b)I have created users usr2222 & usr6666 with Administrator ACL in the above 2 IS resp.
c)I have set the configuration settings in the wMMonitor,wMOptimize & wMTaskClient package homepage for both the IS.
d)wMMonitor of IS2222 in w1 point to MWS:8585 in W2 machine with Administrator as MWS user.
e)wMMonitor of IS6666 in w2 point to MWS:8585 in W2 machine with Administrator as MWS user.
f)wMOptimize for IS2222 in W1 points to BrOPTIMIZE broker in the broker server BS1 in W1.
g)wMOptimize for IS6666 in W2 points to BrOPTIMIZE broker in the broker server BS2 in W2.
h)Created the remote server alias for both the IS in resp. IS administration portal.
Database
a)I have created 4 oracle database users schema IS,MWS,PROCESS & ANALYSIS and installed required objects as below:
-MWS : My webmethods server
-PROCESS: all process related stuff like PRT, process engine etc
-Analysis: Analysis
-IS:All others like core audit,xref,doc hist,TN,internal, archive,staging, reporting etc.
b)The Process Engine & Process Audit functional alias for both the IS are pointing to PROCESS schema.
c)The central user functional alias for both the IS is pointing to MWS schema.
d)Other functional alias for both the IS is pointing to IS schema.

MWS settings
a)Created and deployed successfully one optimize for process environment in MWS. Used the optimize for process template and then added additionally 1 broker server, 1 data collection service and one prediction engine to it.

Now my requirement is that
a)WDC1 should service the IS2222 in W1 and send all the data to BrOPTIMIZE in BS1 in W1.
b)WDC2 should service the IS6666 in W2 and send all the data to BrOPTIMIZE in BS2 in W2.
c)IDC should service both IS & all broker server in W1 & W2 and send all the data to BrOPTIMIZE in BS2 in W2.
d)AE1 in W1 should collect the data from BrOPTIMIZE in Bs1 in W1.
e)AE2 in W2 should collect the data from BrOPTIMIZE in Bs2 in W2.
f)AE1 & AE2 will co-ordinate with MWS in W2.
g)Since AE1,AE2,PE & MWS all are connected to the same database, all the data are stored, analysed, reported through
a single MWS.

Sorry for such a lengthy description. Actually I wanted to depict the situation completely before asking questions.
Though I have browsed through the webmethods PDFs, still not able to get a clear idea on the following:

  1. How to & where to specify that WDC1 should collect data from IS & Broker servers running on W1 & WDC2 should collect data
    from IS & Broker servers running on W2? - is it through the map Server & Map Endpoints tab in environment definition in mWS? But nowhere we are specifying the IS-WDC link?
    2)How IDC will know which machines to monitor?
    3)As per webmethods security recommendation, I have disabled the Administrator user in all the IS and instead created a separate user with the Administrator ACL. But whenever MWS is trying to connect with those IS, MWS is presenting the default Administrator credential.Where to specify in MWS the new administrator equivalent user instead of Administrator?
    4)With the above setup, I am not able to discover IS servers in MWS in Administration/Analytics/Discover asset. I could discover broker servers,but for IS the status remains “Requested”.
    5)Can the IS functional aliases Process Audit, Process engine & MWS database pool for process.model-Analytic engine,process.work/history-Analytic engine refer separate schema?
    6)Though webmethods PDF say that when u install optimize, webservice data collectors get installed automaticall, but I have checked that you can install only Analytic engine part of the Optimize only without including WDC. Will that work?
    I understand these are too many questions, but somehow I am not able to find out all the configuration points through which all these components like IS,Broker,WDC,IDC,AE,PE,MWS & database schema can be tied and work together to give a complete flexible optimize for process & infrastructure environment?
    Pls. let me know if you need to know any other details that I might have missed.
    Thanks in advance.

hello
i wanted to know how you have solved your problem with discovered assets remaining at “Requested” status.

I’m having the same problem and don’t know how to solve it.

any help would be more than appreciated :slight_smile:

thanks