Provider Webservice Input Document Update not reflecting in wsdl

Hi Experts,

I have added new fields to my provider web service input document but those fields are not getting reflected in wsdl file.
I have tried to reload the package as well as restarted the server but it didn;t worked out.

When I tried creating a new webservice then new fields were getting reflected in it.

I have a situation where i can;t create a new provider webservice and has to use the existing service only.

Could you please guide me on how to refresh existing provider webservice so that new fields also get populated in wsdl.


Are you trying to regenerate new WSDL and the new fields doesn’t show up is that your question?

If yes did you also try recreate Provider WSD and check it?

Hi Rmg,

Yes, after adding the new fields I have clicked on view wsdl but new wsdl is not having new fields.

One strange thing that I have noticed is that this provider webservice is not editable, i.e. i am unable to add any new binder/operations etc. to it.
I have set all ACL’s to anonymous and reloaded the package but of no result.

This provider webservice was created few years back and hasn’t been modified till now. Could it be a reason that due to deployment it might got corrupted?


Hi Amit,

Which version of IS are you using? Also are you referring to new fields in service I/O signature?. Add input/output in your original service and refresh your provider, it should work.
Correct me if i am oversimplifying your question.


I got your point…But please review the above Niteesh’s suggestion and try that procedure for refresh.