projectautomator.bat will NOT deploy IS package

Hi all,

I am writing about WmDeployer’s automation “projectautomator.bat”.

  1. I created a VALID deployment, because when I click on Deploy (in the Deploy) section of WmDeployer, the package gets successfully installed on the IS server (local - nothing fancy just yet).

  2. Now when I export using “Export to Project Automator”, it produces the XML file that I must modify the ${parameters} to correct values. I did this and also corrected the argument overwrite = true so that the project gets recreated.

ALL THAT WORKS FINE.

BUT when I run “projectautomator.bat” along with my XML file, it produces NO ERRORS but it DOES NOT deploy the IS package on the local server…!

Now we are working on 9.7, I had this working 100% of 9.6 and we even installed FIX 3 for WmDeployer thinking maybe it could have been a problem…

When I look at the “ATTACHED” report - it seems as if NO DEPLOYMENT of the ZIP is occurring. It’s as if it does all the steps to recreate the Deployment set but does not actually DO IT?!?!

Thank you in advance for your time and effort,

Kristopher R. Kycia

projectAutomatorReport.xml (2.05 KB)
MyTestDeployerProject_ProjectAutomator.xml (1.75 KB)

Well it seems that automation only allows for configuration of the deployment NOT the ACTUAL deployment itself.

A colleague of mind is certain that we must use the Deployer.bat to do the actual deployment.

Conducted some tests and deployment works with the Deployer.bat file…

Thanks for anyone who took a read at this issue… The issue is resolved.

Many thanks.

yes. Projectautomator only creates the deploymennt project but doesn’t deploy.

You can use the deployer.bat to do the actual deployment after creating the deployment project either by using the projectAutomator or by using the UI

Deployer.{sh|bat} --deploy -dc deployment_candidate -project project
-host host -port port -user user_name -pwd password -force
-reportFilePath report_path

1 Like

The only problem I (we) have about the “Deployer.bat” is that it REQUIRES passwords to be specified in PLAIN-TEXT.

This is a problem since we are working on defining a proper CI environment.

We’re going to look “dumb” if we tell customers: “You have to put your Admin password in the batch file in plain-text so it can properly call the Deployer.bat file”…

The “projectautomator.bat” ENCRYPTS password. Would be NICE if the Deployer.bat could DECODE those encrypted passwords ALSO…

Thanks,

Kristopher R. Kycia

In this case it might be a good idea to open a feature request at brainstom for this.

You will need Empower access for this. “Extranet + KB” should be sufficient.

Regards,
Holger

1 Like

Hi All,

I was able create the deployer script for automated deployment, however deploy step is going into infinite loop. I have attached deployer.bat script which I prepared.

Please let me know your thought of deploying only once using the script.

Regards,
Sastry
deployer_demo.bat (4.37 KB)

Hi Sastry,

First thanks a lot for your script.

  1. First error in the script (which not the one that will go into the infinite loop), inside “:describeBuild” you set
    set nextAction=buildit (this label does not existe)

  2. by Setting nextAction=importMap, you’ll have the infinite loop, and this is because when you come to your last step which is “deploy” your nextAction=deploy
    so deploy is executed and it steps to “:VerifyStatus”, and once “:VerifyStatus” is executed it goes to nextAction (which is ‘deploy’)

so the infinite loop is
deploy -> VerifyStatus
VerifyStatus -> deploy

and so on

you need to set your nextAction=FINISH inside ‘:deploy’ block

Regards

Hi SidiM,

Thanks for your suggestion, I put FINISH tag and now the issue is fixed, packages got deployed once only :slight_smile:

Regards,
Sastry

Hi All,

We are on 9.10 wM trying to build Automated build and deploy.
All our IS servers, Jenkins, ABE Deployer are on linux machine.
Can any one of you share me the projectautomatorUnix.sh and deployer.sh files.
What should be written inside these scripts.

Thanks & Regards,
Monica

Hi Monica,

please share the applied Fix versions for IS, ABE and Deployer with us.

These scripts should be present by default when Deployer and ABE are installed.
If they do not, then there might have been an error during installation.

Regards,
Holger

Hi
We are on 9.10.0.0 version with no fixes.
Can you please let me know the path where we can find the projectautomatorUnix.sh and Deployer.sh

Thanks in advance.

Monica

Hi Monica,

these scripts can be found under the following directory:
IntegrationServer/instances/default/packages/WmDeployer/bin

Regards,
Holger

Hi all,

This is regarding ProjectAutomator.xml.

By using Jenkins and Ant scripts, I am able to extract the packages from SVN.

I am not able to pass the list of packages to ProjectAutomator.xml file dynamically.

For example: I have 2 Packages in SVN (Package1 and Package2). These are extracted to CI machine successfully.
Now by using ProjectAutomator.xml file I want a deployer project to be created, but to do that, I need to add manually these 2 packages in ProjectAutomator.xml file (below is an extract from this file). Is there a way I can dynamically pass package names?

<DeploymentSet autoResolve="full" description="Demo_Set" name="Demo_Set" srcAlias="DEMO_Repository">
		[b]<Composite displayName="Demo" name="Package1" srcAlias="DEMO_Repository" type="IS"/>
		<Composite displayName="Demo" name="Package2" srcAlias="DEMO_Repository" type="IS"/>[/b]
	</DeploymentSet>
	<DeploymentMap description="Demo_Map" name="Demo_Map"/>
		<MapSetMapping mapName="Demo_Map" setName="Demo_Set">
			<alias type="IS">DEV_IS</alias>
		</MapSetMapping>
	<DeploymentCandidate description="Demo_Candidate" mapName="Demo_Map" name="Demo_Candidate"/>
</Project>

Hi,

I have tried to run deployer automation. First have created deployer project using “projectautomator.bat” and passing automation script. Using automation script I have passed repository based deployment , so it didn’t generate any build step. When I have tried to run deployer.bat script using command as

Deployer.bat --create -dc DemoDC -map myDeploymentMap -project Test123 -host http://localhost -port 5555 -user Administrator -pwd manage

getting two error

  1. BuildName =null

  2. “[DEP.0100.-999] Service Error wm.deployer.UIAuthorization:checkLock” . On further checking on target server can observe below error " [ISS.0053.0002C] Access denied for user Administrator on port 5555 -> ‘ws/wm.server.deployer.spi:wsProviderV2’ from 13.59.61.2."

Automation script passed in “projectautomator.bat” as below
Test_Test_ProjectAutomator.xml (1.75 KB)