Process Build fails: Unable to create queue

Hello, everyone.

I seem to be unable to resolve an issue with building a BPM process that uses JMS as a start message. Whenever I try to build the process, I get following error output:

Error: Build of process “ImportDispatchAdvice” failed. The log file might have more information.
java.lang.Exception: Unable to create queue DispatchAdvice.
at com.webmethods.process.generator.util.JMSProviderUtil.createNirvanaDestination(JMSProviderUtil.java:85)
at com.webmethods.process.generator.util.JMSProviderUtil.createDestination(JMSProviderUtil.java:227)
at com.webmethods.process.generator.util.GeneratorUtils.createJNDIDestinations(GeneratorUtils.java:744)

Start message settings:
Receive protocol: JMS (For JMS triggered processes)
Receive document: pur:dispatchAdvice
Connection alias: PE_NONTRANSACTIONAL_ALIAS
Destination name: DispatchAdvice

I am running the designer locally, connecting to remote IS. WmPrt dashboard shows no error, UM server is up and running, JNDI settings and JMS triggers PEBroadcastTopic and PERestartTopic are also Connected.

I tried also creating the queue in UM JNDI queues, but even then the error message occurs.

Can anyone help and suggest, what settings shoudl I check or what am I missing?

Thanks, Ivo

Forgot to mention it’s on 9.8 version (IS, MWS, UM, Analytic Engine).

Hi Ivo,

I have tried with JMS as start message and it is working correctly in 98 server.
Please make sure JMS connection alias “PE_NONTRANSACTIONAL_ALIAS” is enable.

Also you have mentioned facing issue while creating queues in UM JNDI,so I think problem is with UM itself.
What error you are getting in creating queue.
You can find more UM log on /serverumserver/data/nirvana.log.

Thanks
Baharul Islam

Hi Baharul.

The PE_NONTRANSACTIONAL_ALIAS is enabled. I checked also the nirvana.log. But there is no information on any kind of attempt of IS/Designer to create the queue. No any other error message either.

Regards,

Ivo

Hi Ivo,

I think this is what you have tried to create queues through enterprise manager/viewer and have got some exception during creation.Then what error you have received at that time.

Thanks
Baharul Islam

Hello again.

I was facing the same issue once again, this time with 9.9 installation. Finally, I think I found the cause and solution. The installation of IS was using a system-generated DEFAULT_IS_JNDI_PROVIDER, which was configured automatically to use URL nsp://localhost:9000. This setup worked for IS, as it was sitting on the same host as UM, but it didn’t work for my local designer.

After changing the URL, it started working.

Kind regards,

Ivo