Problem with JDBC Connection.

hi ,

This is the error i got when i tried to enable the JDBC Adapter Connection. I recently installed webmethods6.1 , then onwards i am getting this problem. This kbgr:kbjdbc is created on the new version of webmethods only.

Theare is no problem with SQLServer Datatbase.

Error encountered
[ART.118.5042] Adapter Runtime (Connection): Unable to enable connection resource kbgr:kbjdbc.
[ART.118.5036] Adapter Runtime (Connection): Unable to configure connection manager.
[ADA.1.200] The JDBC DataSource class
“com.microsoft.jdbcx.sqlserver.SQLServerDataSource” cannot be located.
com.microsoft.jdbcx.sqlserver.SQLServerDataSource.class not found

with regards,
Ramakrishna.

Do you have the SQL Server jars loaded in the /IntegrationServer/lib/system directory? If not, download them from microsoft and restart the IS.

Also make sure the URL and connection information is accurate according to the JDBC users guide provided by webMethods.

List the conenction information you input, as well as the contents of the lib/system directory and the version of SQL Server if you are still having trouble.

HTH
Brian

Check the jar files are placed under /lib directory. If not place he jar file and restart the server. Also check the jdbe connection parameters are correct. You can check in the help section in the JDBC connections of Admin console.

hi,

This is the error i got after adding the SQLServerJars to the IntegrationServer/lib directory.

IS version is 6.1, and JVM is 1.4, SqlServerJars i added to the /lib directory are JVM1.4 compatable which i downloaded from microsoft site.

Error encountered
[ART.118.5042] Adapter Runtime (Connection): Unable to enable connection resource Ramu:SaibabaJDBC.
[ART.118.5036] Adapter Runtime (Connection): Unable to configure connection manager.
javax/sql/DataSource

Transaction Type :LOCAL_TRANSACTION
DataSource Class : com.microsoft.jdbcx.sqlserver.SQLServerDataSource
serverName : sqlsrv
user : webmethods
password : webmethods
Retype password : webmethods
databaseName : webmethods
portNumber : 1433

thanks in advance.,

with regards,
Ramakrishna.

Did you restart the server after copying the jar file?. Make sure the connection parameters are correct as in the manual.

One more point, MS Sql server jar files does’t comes with the required javax/sql libraries, so you need to donwload them from Java site and place them.

The paramaters are ok…maybe consider the full URL if its sqlsvr.yourcompany.net.

I’m sure you saw this in the JDBC User’s guide, but for SQL server the user and pass you use in the connection must be the same that creates the table (i.e. your webMethods user needed to be the user to create the tables initially).

Also make sure that you have your SQL driver and javaxsql.zip in the WmJDBCAdapter/code/jars/static folder. if static folder does not exist create one. restart the server aand check the ‘about’ page. The dfriver should get loaded

The Integration Server packages provide the option of localizing your package related jars. The SQL Server jars in this case can be kept inside the WmJDBCAdapter/code/jars. This is a recommeded best practice for localizing your package related jars under its own code/jars folder and the entire IS related jars under the {IS home}/lib folder.

Thank you,
Muthu