Problem with Inbound UNEDIFACT Document

I’m using TN 6.01 with EDI for TN. I have UNEDIFACT ORDERS that, when submitted to TN, recognizes the outer envelope but that’s it. The inner doc is found as “unknown”.

I don’t have any issues w/X12. My default EDITPA is set to “Transaction” level processing.

Thanks in advance,
Jim Palmer

Have you checked the Activitylog or serverlogs traces.Can you tell us the exact error showing up there.

Innerdoc you mean is UNH transaction level is not recognized?

Thanks,

Server log has not errors.
I’ve included the server log meesage below:

2004-05-07 12:41:20 EDT [ISC.0063.0001D] Create 0ag0b700vhg5e79l0000006v
2004-05-07 12:41:20 EDT [ISC.0063.0001D] Create 0ag0b700vhg5e7ak00000070
2004-05-07 12:41:20 EDT [ISC.0063.0001D] Create 0ag0b700vhg5e7di00000071
2004-05-07 12:41:20 EDT [ISU.0000.9999D] Inserting doc 0ag0b700vhg5e7di00000071 into datastore [TRNSERV.000016.000073]
2004-05-07 12:41:20 EDT [ISC.0063.0001D] Create 0ag0b700vhg5e7fh00000072
2004-05-07 12:41:20 EDT [ISU.0000.9999D] Inserting doc 0ag0b700vhg5e7fh00000072 into datastore [TRNSERV.000016.000073]
2004-05-07 12:41:20 EDT [ISU.0000.9999D] Inserting doc 0ag0b700vhg5e7ak00000070 into datastore [TRNSERV.000016.000073]
2004-05-07 12:41:20 EDT [ISC.0063.0001D] Create 0ag0b700vhg5e7nq00000073
2004-05-07 12:41:24 EDT [ISC.0063.0001D] Create 0ag0b700vhg5ebb200000074
2004-05-07 12:41:24 EDT [ISC.0063.0001D] Create 0ag0b700vhg5ebb200000075
2004-05-07 12:41:33 EDT [ISC.0063.0001D] Create 0ag0b700vhg5ek3a00000076

Yes, the UNH level is not recognized.

Any thoughts?

Thanks,
Jim

I believe you have installed the UNEDIFACT ORDERS doctype? and please make sure that the doctype is not been disabled state.

Yes I have and yes it’s enabled.

The documents I’m using are production documents from a WM 4.01 IS environment.

Thanks for clarifying.

Did you migrated the EDIFACT documents from 4.01 to 6.01 or did a fresh installation in 6.01?

Before routing the document to TN, can you check the validation process if there any errors in UNH level?

The “unknown” you are seeing only under the doctype or sender/receiver section too of TAnalysis?If so the defined processingrule is not success.

Sorry if it won’t help.

HTH,

Ok, I found the issue. The EDI version and release elements are reversed in our production document. When I switched them, it came back OK. I checked the UNEDIFACT guide and found WebMethods handles it ok, our clients EDI is incorrect.

I have come to another issue now. Trading networks accepts and recognizes the document, but when I run “bizdicToRecord” it comes back with the following error, “com.wm.ff.parse.ParseException: [FFP.0012.0004] Found no valid records”.

I checked the inputs and they all look ok. The schema exists in the correct directory.

Any ideas?

Thanks in advance
Jim Palmer

Use the convertToValues (WmEDI service) instead of bizdocToRecord for parsing the edi document.Extract the bizdoc/content(bytes) and map it to convertToValues provided with schema.

HTH,

That worked, thanks.

Strange how it works for X12 but not UNEDIFACT.

Thanks again,
Jim Palmer

Sorry i don’t have any clue,there might be some differences the way it parses for EDI and normal XML messages.

Anyway always its better to use the WmEDI services for edi parsing,validation etc…

Regards,