Problem with adapter and UTF8 (special characters)

Hello,

I’ve got a problem with special characters:
My database (set up in UTF-8) contains special characters (japanese, chinese, or greek…).
When I use a select adapter, wM doesn’t retrieve correct characters.
I’ve the same problems with update adapters.

I’ve read this:
“In the NLS_LANG field of the adapter’s configuration (Oracle Intelligent
adapter), fill in the value “.UTF8” (without the double-quotes and don’t forget the dot in front of UTF8).”
But I don’t know where the field NLS_LANG can be filled-in. (and I don’t know if this field exist for our release: we use webMethods 6.0.1.

Can anyone help us?

Thanks.

hi,

Has your problem resolved? Even we face the similar issue when we use webMethods select template to retrieve the values from the field which have special characters. It would be great if you could share as to what you have done if the issue is resolved.

we use webMethods 6.1 IS.

Thanks
Pearl.

Hi channel,
You wrote:
“In the NLS_LANG field of the adapter’s configuration (Oracle Intelligent
adapter), fill in the value “.UTF8” (without the double-quotes and don’t forget the dot in front of UTF8).”

This solution applies to Enterprise Adapter: DB Edition 4.1.1.

Since you are using IS 6.0.1, you have JDBC Adapter 6.0.1 and that is why you don’t find this option here.

The IS 6.x was tested on AL32UTF8. Therefore, webM recommends to use AL32UTF8. You can choose to use UTF8 or UTF-8 as well.

Refer to page 39 on PlatformInstallGuide.pdf

Also, click on this link for webMethods response on this issue:

http://advantage.webmethods.com/article/?id=SR-1-58154609

HTH,
Bhawesh.

NLS_LANG should be set in environemnt (for example in server.sh).

What I found latetly, is that jdbc thin driver does correct national character mapping without NLS_LANG setting, but jdbc oci needed that.

I have put:
NLS_LANG=AMERICA_AMERICAN.UTF8
export NLS_LANG

At beginning of my server.sh and everything works fine.