Problem while connecting thru workflow client

Hi,
When I am trying to connect through Workflow client, a small window pops up with the buttons ‘Action’ ,
‘Hostname’, and ‘Options’ and the message displayed is" Server may not be active.Waiting to refresh ReleaseNotes.html from hpless01.hpl.hp.com". Any idea why it is saying so? although I did start the workflow server through
Administrative tools->services as explained in the workflow user guide.

Thanks and Regards,
Girish

Hi,

Same problem here.
On one of the discussion notes on advantage.webmethods, it said that workflow does not start as a service. You have to actually execute the start server script. We have tried this, it has not worked.

Has someone actually managed to solve this problem ??

REgards

Hi
I managed to solve the problem, please set the jdk1.3 or later classpath for workflow server and for client .
restart the machine if it is windows NT , if it is solaris, please restart the server only
Selva

In general, this error indicate that webMethods Workflow (client) can not connect to the Workflow server. There are many reasons why this could be the case. The simplest way to find out what is happening is to take a look at the servermgrlog(n).txt files in the Workflow servers log directory. Once the errors are located you can fix the configuration errors and try and start the servers again. Most likely problems are:

  1. The server was not started

  2. The server was not configured

  3. The RDBMS is not active that Workflow connects to.

  4. There is a firewall between the Workflow Client and the Workflow server.

hi,
i saw the log file the message is>>>>>
Failed to load jar with message: “Connection refused: connect” will retry to loa
d servermgrimpl.jar

I have had the same problem. This is what I did to solve it (I’m not sure which of the following steps are unnecessary):
Stop the workflow service and client, Kill as many as possible javaw processes (this might have been unnecessary and some of them didn’t grant me access to kill them). It is strange to me that when you stop the workflow service, that is doesn’t kill al its javaw processes. Anyway, then I deleted all the log files. It prevented me from deleting one that was probably held by the remaining javaw processes. Then I started the WF server by running the srvmgr.bat file. When I started WF client, it did some update and auto-restarted the client and it was fine.

Hi All,

I have installed the workflow server and try to open the workflow and i am getting followin screen. 

" Server may not be active.Waiting to refresh ReleaseNotes.html from MTGV001542"

and i checked in the workflow server logs as you said i can see the logs:


11/24/05 [04:04:43.358 PM] Opened as log\servermgrlog0.txt


11/24/05 [04:04:43.374 PM] [WKS.000.0029] Using Java Runtime Environment version 1.4.2.
11/24/05 [04:04:43.420 PM] [WKS.018.0002] Authentication properties missing. Please see system administrator

Please advice.

You have to configure Workflow using the Configurator Tools from the Program Files.

Hi Pazhanikanthan,

      I have configured the server using the start>programfiles>webmethods>tools. but still i am getting the same error message. Please advice. 

Server may not be active. Waiting to refresh readme.html from: MGVGDC01OR09.

Thanks,

Hi,

I just wanted to add one more thing.
I have restarted the workflow server using the Administrator>service.

eventhough same error message.

Thanks in advance.

Hi All,

 Thanks for your input. I have configured the workflow. I checked the broker its working fine and I can see the workflow documents in broker. 

 Now I am facing problem while adding document. I can’t see the broker document in the workflow client. Can somebody tell the cause?  

Thanks in advance.