Problem when deploying a business model package from one IS to another

Hello!

We have a problem when deploying a business model package (generated with Designer 7.1) from our development IS to a second (testing) IS.

First of all: The process ist running perfectly on the development server.

We exported the package via IS -> Packages -> Management -> Archive and then imported it on the testing IS.
We also transfered (export/import) the related broker documents into MyWebmethods Server. Which worked fine… At least after we installed a hofix for MyWebmethods;-)

The process package seems to import, activate, load and enable just fine (In IS -> Packages -> Management), but won’t run.

In the IS errorlog is the following entry:

java.lang.NullPointerException
at com.wm.isextdc.IsPackage.sendNotifications(Unknown Source)
at com.wm.isextdc.IsPackage.processEvent(Unknown Source)
at com.wm.app.b2b.server.mon.event.MatchAllEvents.processEvent(MatchAllEvents.java:26)
at com.wm.app.b2b.server.mon.event.ISMonEvtMgr.dispatch(ISMonEvtMgr.java:265)
at com.wm.app.b2b.server.mon.event.ISMonEvtMgr.dispatch(ISMonEvtMgr.java:309)
at com.wm.app.b2b.server.AuditIsmConfig.publishAudit(AuditIsmConfig.java:109)
at com.wm.app.audit.AuditFactory.processMessage(AuditFactory.java:1266)
at com.wm.app.audit.AuditFactory$2.handleMessage(AuditFactory.java:431)
at com.wm.app.audit.AuditFactory$AuditProducerHandler.run(AuditFactory.java:1582)

The error message can be reproduced by simply disabling and re-enabling the package in package management.
So it looks like a Webmethods internal problem when enabling the package (No wonder ist wouldn’t run…).

We also tried the same thing with a second process with the same result.

Where could I investigate further? Any tips, hints?

Thanks in advance!

Spectre

… I forgot to mention, that “normal” packages, created with Develper can be imported AND activated without Problems. The problem exists only with packaged created by Designer…

The errors seem to be around auditing. Are your audit settings for the process, the services, etc the same on both servers? For the process it can be set both in the process and via MWS.

Another thing to do would be to look at the manifest files (in the package/ directory on both servers to see if they contain the same information. Doing an archive does not provide the manifest file with the same information a publishing release would have done (or a Deployer release).

Hello PhilLeary, thanks for answering!!! The auditing part is, what puzzles me most since on both IS servers, auditing is disabled. On both MWS, auditing is also disabled. I also tried the publish/subscribe way to get the packages to the second server. The problem still remains the same. The manifest Files are essentially the same, except for the subscription entries on the server, from where i subscribed to the package (name, publisher, patch_nums, etc.). Seems OK to me… Could it be some configuration problem in Designer? Perhaps something went wrong with “Build and upload for execution”? Could it be possible to configure a process in a way that it would only run on a specific server?

Hmmm. Interesting. Did you do anything with logical servers on the steps of the process?

Sorry for my late reply but I was out for about two weeks (prolapse of intervertebral discs ain’t no fun! :frowning: ). We (actually my colleague) finally got it to work by using “Deployer”. It seems, that Deployer actually changes some stuff in the SQL-databases in addition to just copying the packages. Needless to say, this is not done when you deploy the process packages manually (via export/import). I just wanted to report the solution. Thanks (especially to PhilLeary) for the help you provided!

Thanks for posting the answer you discovered. (and sorry to hear about the back).