Problem generating a record based on any DTD IS46 and Developer 461

Hello,

I am trying to generate a record, based on a DTD.

  • I am using jdk 1.2.2_011 (supported, according to wM documentation)
  • I have been successful on another machine (so I guess it must be related one way or another with the my installation)
  • the DTD is 100% correct. I have tried several other easy DTD’s and always receive the same error !
  • I have tried jdk 1.3.1 and encountered the same problem
  • I have been succesful in compiling some java services, so there is nothing wrong with my compiler (I have adjusted the classpath in the server.bat file to reflect the c:\jdk1.2.2 directory)

Here is the error message that I get:

java.lang.NullPointerException

at com.wm.lang.schema.WmElement.createRecord(Unknown Source)

at com.wm.lang.schema.conv.Converter._convert(Unknown Source)

at com.wm.lang.schema.conv.Converter._convert(Unknown Source)

at com.wm.lang.schema.conv.Converter.convert(Unknown Source)

at wm.server.record.generateFromDTDString(record.java:155)

at java.lang.reflect.Method.invoke(Native Method)

at com.wm.app.b2b.server.JavaService.baseInvoke(JavaService.java, Compiled Code)

at com.wm.app.b2b.server.ServiceManager.invoke(ServiceManager.java, Compiled Code)

at com.wm.app.b2b.server.ServiceManager.invoke(ServiceManager.java, Compiled Code)

at com.wm.app.b2b.server.HTTPInvokeHandler.process(HTTPInvokeHandler.java, Compiled Code)

at com.wm.app.b2b.server.HTTPDispatch.run(HTTPDispatch.java, Compiled Code)

at com.wm.util.pool.PooledThread.run(PooledThread.java, Compiled Code)

at java.lang.Thread.run(Thread.java, Compiled Code)

I urgently need to get this to work !

Any help is kindly appreciated !

Jan

Jan, do you get the NPE while using the GUI Wizard or after selecting “Finish”?

Dan,

Thank you for your reply.

I am getting the error after clicking “Finish”, after I have already selected the root node of the DTD.

Any ideas ?

Jan

Jan, have you solved this issue yet? Was it related to permissions on the local drive?

No,

the problem still remains. I have talked it through with a couple of colleagues, working on wM for 6 months and they also don’t know what’s wrong.

Could it have something to do with classpath or path settings ?

Any help is welcome !

Jan

Are you running 4.6 SP1? (You can check the Server UI About page for IS_4-6_SP1). This problem may have been introduced by that update.

Fred, is there a log of other problems that may have been introduced by IS_4-6_SP1? That would be good information to have.

Thanks.

There are two problems that I’ve heard of being introduced by SP1.

  1. The DTD issue should be available for it on Advantage (IS_4-6_SP1_FIX54).

  2. Custom HTTP Headers (as used by EDIINT package) didn’t get propagated through reverse invoke connections (IS_4-6_SP1_FIX65).

Also, There are a couple compatibility issues that could be caused that are documented in the SP1 Readme. The most noticable is that the package ClassLoader has been made smarter making defining package dependencies required to get Java services that directly reference classes in another package to compile.

Fred, Dan,

I am running IS_4-6_SP1, so this could be the cause of the problem. I have searched around Advantage for the fix IS_4-6_FIX54, but haven’t found it, where can I get it ?

Once again thanks for your help !

Jan

Hi Jan,

I ran into the exact same problem that you describe, can not create record from DTD after SP1 was applied.

The fix is available on http://advantage.webmethods.com under FAQs and Known Issues ( user id + password required ).

IS_4-6_SP1_Fix54
Description After applying Service Pack 1, unable to create a record from DTD.

This fix MUST be used in conjunction with Service Pack 1

Instructions 1. Shutdown webMethods Integration Server.
2. Copy IS_4-6_SP1_Fix54.jar into %webmethods%/server/updates
3. Restart Integration Server.

You can not download directly, you send a request for the fix by filling and submitting the form under the IS_4-6_SP1_Fix54 link and get this response:

Thank you for using Advantage. Your request for the fix to this known issue has been sent to webMethods Technical Services and someone will be in contact with you soon.

Shortly after you receive an e-mail with a Service Request number and further instructions.

Regards,

Mikael

…and only 15 minutes later I received another e-mail with the fix (jar + readme) - I tested it and it works!

Thanks Wm support!

/mikael