Performance Tools, Execute Trace - getting JAVA error

It seems like when I try to do a trace of more than say 5 parallel traces, then I get the following error when I click on the the little PDF button.

java.lang.Error: java.lang.IllegalStateException

The trace itself is rather simple at this time (just a simple log in and one or two clicks on the screen). What I am trying to do is see what kind of load my new server can handle, i.e., can I have say 50 users use the application at the same time? My gut feel is that the new server will be able to do with with no problem, but I would like some solid data to back up my gut feel.

As a test, I was able to run the trace 1000 times in a row with no problems for a single thread.

Also, is there a way to change the default port number that comes up on the Execute Trace screen to 8080 from 51000?


ps- see attached trace from JBOSS log.
jboss log.txt (2.8 KB)

Hi Demos,

I am getting this exception when I click on the pdf-button, but the trace-execution hasn’t finished yet.

The port initialization cannot be configured.
A workaround is, to pass the host as parameter in the url when starting the Trace-Execute tool:


Best Regards,

I tried the method you suggested and that works perfectly. Thanks.

I did notice that if I run a test for 10 threads 10 times the trace does not finish. It just seems to stop without any error message. Would it perhaps help to increase the number of threads in JBOSS? I think we are 100 now.