Path has been used error

I have a flow service that extracts data for invoices straight out of the database into webmethods, I’m now building a flow service to massage the database invoice format into what I’m calling a “FixedInvoice” The FixedInvoiceHeader document is the same as DBInvoiceHeader, except it has a few more string items added to it, OrdererEmail, CostCenter, and AFE.

flow service called fixDBInvoices is doing a straight map from DBInvoice to FixedInvoice to first get all the identical data into the FixedInvoice document, then calling another service, fixNotes, which accepts a single DBInvoice as input, and returns those 3 strings (based on the notes in the DBInvoice). but when I try to map that service’s output (the 3 strings) into the FixedInvoiceHeader document’s strings, I get this error:

[ISC.0049.9018] The path has been used:
/FixedInvoice(0)/FixedInvoiceHeader(0)/OrdererEmail(0)

if it helps at all, I had the FixedInvoiceHeader document with extra DOCUMENTS, which then had the strings in them, and I had the fixNotes service output going into THOSE nested strings, but I changed the FixedInvoiceHeader document so that the strings are outside of the docs and on their own. that’s when I tried to re-map the output to the new string elements in the FixedInvoiceHeader.

Hello,
You first want to try to delete the links to the FixedInvoiceHeader and save the service. Then, if the FixedInvoiceHeader did not itself delete (like because it is the services output variable), put the mouse to pause over the variable. If you notice the name something like FixedInvoiceHeader(0) or FixedInvoiceHeader(1), and it is the only one with that name on the pipeline, there is an invisible copy in the xml that represents that flow. Ok, so you shoul make a new step (map or service) BEFORE this one and duplicate what should happen, then delete the original step below. Now when you put the cursor over the FixedInvoice Header, it should be a loner.

I am only guessing based on what I think your problem is, so Maybe an Ascii sketch would help if I am wrong.
Good day.

Yemi Bedu

I think you were correct in that there was an invisible or dangling doc instance on the pipeline. I actually fixed it by going back and changing to FixedInvoiceHeader again, and when I went back to the step, the OLD items appeared, with the links going to them. I deleted those links, reverted FixedInvoiceHeader, and re-did the links to it there and it worked.

This seems like a pretty serious bug? That document instances could still be registered on the pipeline without showing up?