Package disappeared but still exists?

We are using wM 6.5, and I was working on a package in Developer 6.5 when I restarted IS.
Developer showed me the usual “Connection lost” and “Connection restored” messages, but my entire folder had disappeared.

Fortunately, this was QA, so I tried to copy a the package from our prod environment, but it gives me an error. When I try to create a package with the old name it tells me it already exists…

I’m lost as to how to proceed…anyone ever have a similar problem?

Not seen any issue like this…But are you sure package exist in QA…Always try to use deployer for package migration etc…

Did you check/scan entire QA IS/replicate file system folders and logs to see whats going on?

You can self troubleshoot since you know well your environment better than assuming what went wrong which is unknown for us:)


@rmg, thanks for the info. Our deployed does not work correctly (long story), and I’m new to webMethods, so it took me a while to go through the logs and file folders and figure this out, but in case anyone has a similar problem, here is what happened:

Some time ago, someone attempted to install a partial release that was built incorrectly (missing files, etc.). This returned an error and actually deleted a bunch of files from the package (leaving just the package folder and the ns folder within it).
When I restarted IS it did not load that package because even though the folder exists, it does not contain the correct files (don’t know which specific files it needs, but I assume it was missing crucial files).
BUT, when I tried to create a package with that name, the folder was still there in webMethods6>IntegrationServer>, so it returned an error…

My solution: delete both folders, restart IS and install a full release from QA. (and delete the partial release that caused the error, in case anyone tries to use it).

Great…you got it resolved self and thanks for sharing the info here:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.