OpenPGP, no terminal at all requested

When I try to decrypt a file with pub.openpgp:decryptFile I get following error: “gpg: Sorry, no terminal at all requested - can’t get input”.

The cmdline variable when I trace into the decryptFile looks like:
“–homedir “C:\Documents and Settings\wmadmin\Application Data\gnupg” --no-tty --armor --yes --decrypt-files [filename]”

The only hint I found with google was to remove the “–no-tty” parameter. But it is necessary to execute GnuPG in batch mode.

Does anyone has a clue?

The reason was the passphrase that must not be given if gpg runs in “–no-tty” mode. After removing the passphrase (i.e. passphrase="") it worked fine.

Hi,

Where did you change? entry in my openpgp.properties files looks like:

“pgp.decryptfile= --homedir {0} --no-tty --armor --verbose --yes --decrypt-files {1}”

Thanks,
Puneet Saxena

After importing public keys from a file, I tried to encrypt with this public key, and I got:
gpg: 5C128B01: There is no assurance this key belongs to the named user
gpg: Sorry, no terminal at all requested - can’t get input

Is that something to do with passphrase as well? How could I fix it?
pgp.encryptfile= --homedir {0} --no-tty --armor --yes --recipient {2} --encrypt-files {1}

Thanks,

Kathy

I figured out the problem. imported key needs to be signed before using it. wM OpenPGP sample document mentions this on page 5.

After I signed the imported key, it works just fine.

Kathy

I am trying to encrypt a file after all the configurations were done correctly and receiving the following exception.

gpg: out of memory while allocating 128 bytes. Does any body has any idea?

Kathy, since you were able to encrypt the file successfully, can you tell me what is the memory allocated for your JVM?

Appreciate your reply.

Kathy,

Can you also tell me what JVM version are you using?

Thanks,
Usha

We are using Linux with JVM1.4.
I do not think the OpenPGP service is actually using JVM memory. It simply sends the command to OS. We encrypt files which have 2 or 3 MB size without problem. You may try to encrypt a file in your commad line and check the result first.

Thanks for your reply. I am able to encrypt the file successfully from command line. But not able to do the same from IS.