Only 1 DDM ( FDT ) CALLNAT 'USR1043N'

Hello,

I have a program where I get the columns from a database in a file, but it requires to get only the columns from an DDM (FDT), not all from the DB.

I am occupying CALLNAT ‘USR1043N’

NM LV F LEN


HB 1 A 4 <-- DDM A
HC 1 A 5 <-- DDM C
HD 1 A 15 <-- DDM A
HE 1 A 5 <-- DDM B

I only need the ones from DDM A

Thank you,
Greetings

Ricardo,

use USR1058N to read the DDM

1 Like

Hi.
I am using ‘USR1058N’ but it tells me the following message:
MSG-NR: 999 MSG:
Function is not implemented

Could you tell me that I am missing or will you have a working example?

thanks,
Greetings

When I run USR1058P out of SYSEXT on Natural 9.1 / Linux I get, for example

Hi.
Could you share an example of the code with me.
thanks

Just have a look at USR1058P in Library SYSEXT !

hence take my example, which sends me the message 999.

thanks

What environment are you running it on ?

Natural v6.3.1 on a Unix operating system.
Thanks

Ricardo,

I’m wondering what value you assigned to the OPT-ACCESS parameter before calling USR1058N? It looks like only “O”, “R”, and “C” are valid, as explained in the USR1058T description below:

Input ...... OPT-ACCESS (A01)
                    Access type. An open call starts the processing
                    and returns the directory data. The next calls
                    read the object until its end. The close call
                    is done automatically by the subprogram.
                    Possible values are:
                    'O' - Open processing
                    'R' - Read source lines
                    'C' - Close processing; only necessary in
                          a file system environment to force the end
                          of processing.

Leaving it blank or some other invalid value might result in the 999 Function is not implemented message you are getting.

Hope that helps. If not, it would help if you could post the code you are using to call USR1058N and maybe somebody will spot what you are missing.

Good luck,
George

1 Like

Just tried USR1058P on NAT 6.3.13 / Linux and this works as expected,
so not sure what your issue is, I can’t test on anything lower than that version, I’m afraid.

Thank you.

I’ll try to do some tests in my library.

Greetings