Hi All,

While tracing am getting error as com.wm.app.b2b.client.ns.NSRuntimeException in Enterprise One Adapter service in wM6.1.


How to request help to maximize useful responses

Give details as to on which step you are getting this exception. Check whether you are using a transformer service in a map step which takes one input and for which you are passing an array as input.

Hi ,

I’m using SAP Business connector 4.6. While running a flow service in a test environment I get this error: “com.wm.app.b2b.client.NSRuntimeException”. I’m running the service step by step in BC developer. When I run it via IE it does not give any error and just exits w/o error. The error occurs at different steps in the flow service everytime I run it so i’m not sure what is causing this problem. Sometimes it occurs in a ‘map’ step where I’m just using a trim function for strings. Else it errors out at a ‘branch’ step for no reason.

There is no error in the error log for same.
Most of the times the BC developer hangs after this error occurs.
Also and it keeps givign outOfmemory exception whenever I try to save a change in the service.
Any help in this regard will be grealty appreciated.

I’m unable to find a solution for NSRuntimeException on wmuser. Sree can you please let me know how you solved NSRuntimeException issue.

Even I’m looking for a definitive answer for same. Though in my case I found a way to resolve this for now. My service was huge and guess was using lots of memory. I optimised the code and dropped variables at each n every step to save as much memory possible and it worked. You can try this too.

Does you developer/server hangs too after you get this erro?.. It seems that NSruntime issue arises due to memory issues. Try this and let me know if it works.



The developer is not hanging on me but the code was successfully tested in SAT environment. Then the code was migrated to new server (SunOS 5.9) which is throwing an NSRuntimeException.

Both the new and the old servers heapsize is 512.

Can there be any other issue.

It was working fine for me too in production envt but when I tested again in QA evnt the same code refused to work. When you trace through the service does it fails at same step everytime? you can still try what I suggested earlier.