NSC---L used to check user-access to library. may have an error.


When i use PGM—L to test NSC—L I get the right answer when I uses my own user-id as parameter. If I use any other user-id i get returncode 828 (You may not logon to ‘SYSSEC’).
I had the other user doing the same, and had the same result, only the user had acces but not me.

It looks like NSC—L may be using *USER and not the parameter.
Using *USER as default if parameter is not filled is fine, but not if user-id is valid.

The reason why I’m using this module is that LOGONUS will show the current library when there is an error trying to logon to another library.
Using NSC—L in your system would be working, but not good for testing.

I suspect that Natural Security allows execution of NSC—L for one’s own user ID, but blocks it for other IDs if you are not authorized for access to SYSSEC. You may be able to circumvent this by copying NSC—L to a library in your STEPLIB chain. Otherwise I think you’ll need to be linked to SYSSEC.

Sorry. I cannot test this myself as I don’t have the necessary access to a secured Natural environment at the moment. Perhaps if you posted source member PGM—L to this thread …

Source for testing NSC—L.
pgm—l.txt (5.09 KB)

Thanks for posting PGM—L, but I get the same error 828, even when NSC—L is in my own library.

Years ago I embedded a CALLNAT to NSC—L in a utility which was used by the entire development team, none of whom had access to SYSSEC. I’ll let you know if I remember how I got that to work.

I suggest a call to SAG Support.