Not able to get any data from Raspberry Pi onboard sensors

Hello,
I was successfully able to register my raspberry pi 4 to Cumulocity tenant and I can even see it on device management page. But am not getting any data except for location and when I try to select data points it lists out LED’s and Button’s which don’t provide any data to it. For example I would like to monitor Raspberry Pi CPU temp, Disk Usage etc, is it possible to do that or do I have to write some external scripts. If scripts, could please provide me a guide to what kind of script and then how pass that data to Cumulociity.

Thanks & Regards,
Suvrajeet Kund

Hi Suvrajeet,

When you select data point in GUI, check the http response for ‘supportedMeasurement’ and ‘supportedSeries’ http requests using browser’s dev tools (in chrome press F12 and select network) . If the response does not show the supported sensors then I think it is not supported in the agent which runs on Raspberry pi.

You can use REST calls to connect pi to tenant and post the sensor values. For more information about REST with cumulocity refer https://cumulocity.com/guides/device-sdk/rest/ . I think you have to write scripts to use this. The script (python is easier) should collect information from pi and post them in your tenant.

Regards,
Lohith

Hi…I just tried it on a different pi board. still giving the same error. looks like its not the CSI port.
maybe the cable? I’m gonna try formatting and reinstalling raspbian. Not sure how its going to help but i hope it works. save me from the hassle of trying to get a new camera module.

Hi Lari,

did you have any success with your tries?

best regards
Michael