No drag-n-drop from Windows to mainframe

We have standard installations of Nat6.1.1.17 on WinXP PCs with a common FUSER on a Win2003 Server. Via SPoD (NDV214 on zOS) we can drag-n-drop Natural objects between Server libraries, between mainframe libraries, and between Server and mainframe libraries.

In testing a Nat6.2.4.0 Client installation (WinXP) running against a Natural Server (Win2003), we receive a NAT0999 - Internal error when attempting to copy a module from Server to mainframe. All other combinations of Server/mainframe libraries work fine.

Is this an installation issue? Configuration issue? Communication issue?

I’ve tested with Natural Studio 624PL0 and NDV214SP09 Mainframe server with NAT414SP4. And I can drag 'n drop sources from my local environment to the remote environment without any problems.
Do you run the most recent versions of NDV21 and NAT41?
Is it a drag 'n drop from local environment to the remote environment if you say

NDV214 is running as a batch server - I don’t know at what patch level. Natural is at 414. Again, I don’t know what patch level or service pack, but I’m trying to find out.

Whether I drag-n-drop or use the context menus to “copy” and “paste” from the local Server to the remote Mainframe, I see the Copy Object(s) window immediately overlaid with a window containing Error - NAT0999.

This message was found in the NDV server job:

I’ve browsed our Support Information System but can not find any relating entry/solution.
A bypass could be to run NDV with KEEP_TCB=YES.
I’d recommend to ensure that the most recent versions are installed. And if the problem persists open a support request. Set NDV trace to TRACE_LEVEL=31+27+23. Reproduce the problem and attach the corresponding trace output to the support request.

Any luck with this one Ralph? I have a NAT6.2.5 PL 00 machine accessing NAT4.1.4 PL07 via NDV 2.1.4 PL06 without any problems, but I also have NSC on both Natural environments. Other NDV settings we are using (note: trace level 31 is because this is my testing environment only, minimal activity):


I don’t have access to the NDV parms; they’re controlled by our Data Center staff. The mainframe has NAT414 and NDV 214 (batch), both at SP8, I’m told. I’ve reviewed the documentation of all the NDV parameters, but I don’t see anything that could cause my problem.

I replaced my NAT624 Server installation with a standard NAT625 installation, and then replaced that with NAT631. None of these versions resolved the problem. I removed 631 and installed a standard 611 and it worked as it should. Now I have a standard 611 and the client portion of 625 installed on my machine, but only the older version allows me to copy/paste from server to mainframe libraries.

If you can’t even browse the NDV output to see the trace info or basic settings your hands are really tied! We haven’t needed to make any changes to our NDV settings used with NAT6.1 since I started testing NAT6.2 & NAT6.3, so I’m really at a loss for suggestions.

I’m sure you have tried all these things already, but just going to throw out some questions…
Does copy/paste from MF to PC work?
Is the result same for all libraries/sources?
Does move/cut work?
Any idea for the number of active NDV connections?


When we began testing of Nat6.3.3 against NDV214 our copy/paste issue was resolved.

We’re now testing a NAT633/NDV223 combination. The migrations continue to work properly.

We’re still trying to resolve the timeout issue, where Natural Studio locks up when inactive for an extended period.