New to webmethods need help

i am trying to write a simple addition i know it sounds dumb but when i run it it says ServiceException: Service not opperational.

Can some one help me out

Try to recompile the service by making any change in the code. even enter a space at the end. This will give you the right error.
Thanks

There’s also a transformer that will do additions for you so you don’t have to write your own, under pub:math.

it say’s com.wm.util.LocalizedIOException: unable to locate or start compiler

Sounds to me like you just have the Java JRE, not the JDK installed. You might need to install the JDK and/or change the “JAVA_ROOT” variable in \bin\server.bat (for NT/Win2K, server.sh for Unix) to get this work.

I’ve had the same problem, so I’ve installed the Sun JDK 1.3.1, changed the JAVA_ROOT and rebooted the Integration Server, then it worked.

Hi, bob.

You may find some help at http://www.wmusers.com/wmusers/messages/117/170.shtml.

Thank you

it worked fine thankyou. Now i have another dumb question
how to change
public static final void add( IData pipeline ) throws ServiceException
default to some thing else?

thanks for your help