new "select"-tag

X-Application Version: 3.1.2
Tamino Version :3.1.1
Platform : Win2k
WebContainer : Tomcat 3.3
JDK Version : 1.3.1

I just downloaded and integrated the new tags (select and count) into my “learning environment”. FillSelect didn’t do the trick before so I tried select.

What I want to do is:

Get a list of all Keywords from an XML file and show them in a select-control. It works fine if I use an element that may only occur once (1) but as soon as I use the control for (*)-Elements I get tons of errors.

The structure looks like this:

-
Warum ist die Orange rund?
So halt
Obst
Geometrie


I have no problems getting all “Fragen” into the select-Box, but with “Stichwort”

<bdm:select text="/testcase1/Stichwort sortall(.)" value="/testcase1/Stichwort sortall(.)" distinct=“true”>

I get errors starting like this:

Sorry if this is just one of these RTFM-Questions, but I’d really appreciate if one of you could give me a hint.

Thanks a lot,
Ralf

org.apache.jasper.compiler.CompileException: C:\diplomarbeit\ino\xapplication_312\examples\jsp\simple\selectexampleRalf2.jsp(15,11) Attribute module invalid according to the specified TLD
at org.apache.jasper.compiler.TagBeginGenerator.validate(Unknown Source)
at org.apache.jasper.compiler.TagBeginGenerator.init(Unknown Source)
at org.apache.jasper.compiler.JspParseEventListener$GeneratorWrapper.init(Unknown Source)
at org.apache.jasper.compiler.JspParseEventListener.addGenerator(Unknown Source)
at org.apache.jasper.compiler.JspParseEventListener.handleTagBegin(Unknown Source)

/* */

(pls. see “schema” above)

<bdm:select text="/testcase1/Stichwort sortall(.)" value="/testcase1/Stichwort sortall(.)" distinct=“true”>

brings up all the keywords - not “distinct” but every single occurance. How can I drop those that accur more than once?

Probably distinct needs some kind of record id? But since a keyword (Stichwort) can occur in several records, the ID is of no use for me here.

Thank you, Ralf.

Hi Ralf,

I have tried to reproduce your problem with several schemas, but it works fine and your problem didn’t occured.

When using the select tag with identical text and value attribute, you can omit the value attribute within the tag, because this is the default case.

Probably this will solve your problem.

Bye
Thorsten

Hi Thorsten,

omitting the explicit “value”-Parameter works. Thanks for helping. I hope, once I break through the clouds and see the sun I can contribute something here…

Ralf.