New length not being taken from new IDL and XMM in aar or WSDL when generating web service

Running EntireX Designer 8.2.2.52.25… had a request to rebuild the aar file & WSDL as one of the parameters increased from A18 to A20 in the Natural subprogram PDA.

I went through the steps to regenerate the IDL from the Natural subprogram, and both IDL and XMM seemed to pick up the new length ok as I can see STYLE-NUM is now A20:

Then I generated the web service from the IDL and it warned me it would overlay it which is ok. After getting the message the web service was generated, though, the WSDL still shows the old length:

<xsd:element name="_STYLE-NUM">
xsd:simpleType
<xsd:restriction base=“xsd:string”>
<xsd:maxLength value=“18”/>
</xsd:restriction>
</xsd:simpleType>
</xsd:element>

Why wouldn’t it pick up maxLength value=“20” from the new IDL and XMM files?

I tried deleting the existing aar and WSDL files but they come back right away.

Does anyone know how I can get it to do what I expected?

Thanks,

Brian

I solved the problem by deleting the IDL, XMM, AAR and WSDL files from the file system and starting over. I shouldn’t have to do that I wouldn’t think, but it seemed to work that way. Otherwise it looked like the XMM wasn’t really being updated.

I cannot reproduce this behavior with EntireX Designer 9.5.